iPhone Unlock, PLEASE HELP!!!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Wiljo5, Nov 23, 2007.

  1. Wiljo5 macrumors newbie

    Joined:
    Nov 10, 2007
    #1
    Please help me, I bought an iPhone yesterday (apple.com) and now im worried cause im sure (no 100% though) that the iPhone will come with version 1.1.2. And i've researched alot (after buying the iPhone, unfurtunetly) about unlocking version 1.1.2 and i think it says pretty clear in every website (that i've looked at): It can't be unlocked!

    So I am very, very worried about this situation. But like I said, im not 100% sure it can't or it won't be unlocked. So can anybody help me please!!! (if anybody knows if it will be unlocked (1.1.2) or if its been alrady unlocked please tell me when or how!!!)


    PLEASE HELP and Thank You, Wiljo5!
     
  2. iliketomac macrumors member

    iliketomac

    Joined:
    Nov 22, 2006
    #2
    Yours will have the 1.1.2 firmware. I'm 99.99% sure. If your serial number has week 45 or 46 or beyond, then I'm 99.99999% even more sure. No unlock YET... so BE PATIENT. The Dev Team is working on it... so no sense in panicking, just don't open it in case you want to return it for a full refund within 14 days of purchase. Stay :cool: .
     
  3. iliketomac macrumors member

    iliketomac

    Joined:
    Nov 22, 2006
    #3
    Yours will have the 1.1.2 firmware. I'm 99.99% sure. If your serial number has week 45 or 46 or beyond, then I'm 99.99999% even more sure. No unlock YET... so BE PATIENT. The Dev Team is working on it... so no sense in panicking, just don't open it in case you want to return it for a full refund within 14 days of purchase. Stay :cool: .


    Nope no can do as of today... the bootloader will still be 4.02.13G ---> therefore the iPhone stays LOCKED.
     
  4. Wiljo5 thread starter macrumors newbie

    Joined:
    Nov 10, 2007
    #4
    do you think there will be an unlock (when???)?????
     
  5. Wiljo5 thread starter macrumors newbie

    Joined:
    Nov 10, 2007
  6. -M7- macrumors member

    Joined:
    Feb 14, 2006
    #6
    Have patience...

    If you are lucky then there will be an unlock for 1.1.2.
    It wont help if you panick, though.

    Nobody can tell when a solution will be ready. Who knows the future?
     
  7. user1524 macrumors member

    Joined:
    Sep 25, 2007
    Location:
    Bombay , India
    #7
    iv got the iphone 1.1.1 unlocked version here in india


    5 days back it suddenly said

    iphone needs repair cannot make or receive any calls please contact apple.com etc


    any fix for this ? im going crazy trying to find some info online how to fix this

    SOMEBODY PLEASE FIND ME A CURE

    Ps: sorry for caps but im getting really desperate now :( :confused: :mad:
     
  8. spinstorm macrumors 65816

    Joined:
    Sep 14, 2007
    #8
    Apparently when this has happened that means the phone is broken.

    If you have restored it using iTunes and it still does it then I'm sorry....

    Sounds like it was defective to start with (or the unlock broke it) - but seeing as you unlocked it AND your in India you can't get it fixed by Apple.

    It can be fixed independently I believe but by the time you do that its probably cheaper to get a replacement phone.

    Very unlucky!

    http://cre.ations.net/blog/post/my-iphones-radio-fried---can-i-have-yours

    Same thing happened here - I guess you will be buying a new phone...
     
  9. CD3660 macrumors 68040

    CD3660

    Joined:
    Jun 6, 2007
    Location:
    Cheshire, United Kingdom.
    #9
    It was the anxiety that something like this would happen that finally persuaded me to wait for the official release of the iPhone in the U.K.

    I am glad that I did. I may have paid more (taking the contract into account) than I would have for an unlocked phone used with a different network, but at least if anything goes wrong I have full consumer rights.

    Good luck with sorting out this problem. :)
     
  10. MishoM macrumors newbie

    Joined:
    Oct 13, 2007
    #10
    Well then just return it and go to some empty AT&T store and get one from them. I bet they don't sell that many and still have some of their older stock. :)
     
  11. user1524 macrumors member

    Joined:
    Sep 25, 2007
    Location:
    Bombay , India
    #11
    Here ya go:

    Pakal and I followed this tip but since the phone was not unlocked ever, we ierased the baseband then simply restored and voila...

    Credit to Citrus for this....

    OK, everyone who has done any sort of hacking, flashing, restoring etc. and ended up with an iBrick with the following symptoms:

    IMEI: Unknown ICCID: Unknown, Rapair Needed (iPhone cannot make or receive calls), no audio (except headset), no WIFI i.e. corrupt baseband or baseband flash is in a limbo state and cannot communicate with ieraser or bbupdater, then the following solution MAY resolve your issue. I did this on a 1.1.1 iPhone which I had hacked a dozen times and had gone from 1.1.1 to 1.0.2 and back and forth etc, because of the above symtoms, until I discovered a very easy way to resolve the problem. After all it's only software, thus I don't believe it's possible to damage your iPhone permanently by just the software and baseband tinkering. I recommend you read this entire procedure to understand what is being done, prior to diving into it. Read each step BEFORE attempting it, so you can follow the procedure exactly as it is written and avoid possible mistakes. We will do everything via Mobile Terminal on the iPhone, since your WIFI does not work due to the corrupt baseband.

    I have Macs and an XP machine and yet to my surprise, I found this solution to work extremely quick and easy with Windows. Due to the condition my iPhone was in, iNdependence and various other activation apps could not activate my iPhone because my ICCID was unknown. So, I used a Windows laptop and it worked, with PAYCAY! Please note, I did all this without a SIM card in my iPhone, until I fixed it and then inserted my SIM card . In all the procedures, the various apps will ask you to reboot your iPhone, sometimes several times, it is OK!

    You need to download the following tools: AppTappInstaller.exe, PACAY and iBrickr_0.91.

    Also download the following files: ieraser, bbupdater, secpack, ICE03.14.08_G.eep and ICE03_14_08.fls

    1. Get your iPhone to 1.0.2, if you are already at 1.0.2 with the yellow attention triangle on your iPhone screen, go to step 2. If you have the cable with the iTunes logo on your screen, it means you are at 1.1.1 and perhaps don't know what to do. Connect your powered on iPhone to iTunes, click away any message iTunes displays about your phone and make sure your phone is recognized by iTunes. Now hold both home and power/sleep button for 10 seconds, then release only the power/sleep button. While still holding the home button, you are waiting for iTunes to pop up a window telling you it has found your iPhone to be in recovery/restore mode. As soon as it does, let go the home button. Your iPhone screen should be blank (black). If you are seeing the iTunes logo and the cable connect again, then you will have to repeat the previous instruction.

    2. Your phone has the yellow triangle (this means your at 1.0.2). Now connect your phone to your XP machine and run AppTappInstaller.exe. The first time it will fail, close AppTapp then start iTunes until you get an error message from iTunes then close iTunes again, including the iTunes Helper process. Now run AppTappInstaller.exe for a second time and wait until it is finished, it should run to the end with a success message. Go to step 3.

    3. If you downloaded PAYCAY and unzipped it, you should have a "MACOSX" folder and a "YouTube (Windows) fix" folder. Open the Windows folder and double click on "(CLICK HERE) activate.bat". Follow the instruction to reboot your phone. You should now have an activated iPhone at version 1.0.2, go to step 4.

    4. Start iBrickr and go to Applications, follow the instructions to install applications. After rebooting you phone several times, you should now be able to install apps. Browse for the following apps and install them: "BSD Subsystem", "UIctl" (by Nate True) (or use Launch Gui by Erica Sadun same thing) and "Mobile Terminal VT100". Make sure these are installed, you can verify by refreshing the app list in iBrickr. On your iPhone go to your home screen and see if the 2 apps, UIctl and Terminal are installed. Sometimes I had to install the apps 2 or 3 times, until they actually were installed. Now copy the following files to the /usr/bin/ directory on your iPhone: ieraser, bbupdater, secpack, ICE03.14.08_G.eep and ICE03.14.08.fls. Go to step 5.

    5. Tap the Terminal in your home screen. You will see a command line. Type the following commands followed by enter: chmod +x bbupdater
    chmod +x ieraser
    chmod +x secpack
    chmod +x *.fls
    chmod +x *.eep

    Now press your home button and go back home, tap the UIctl icon. CAUTION, do not play around with the services by stopping or unloading them without knowing the affect. You need to tap on only the following services:

    Tap on com.apple.CommCenter - you will be given several choices, just tap "unload -w"
    then tap on com.apple.mobile.lockdown - again you will be given several choices, just tap on "stop" and go to step 6.

    6. Now go back into Terminal and type "ieraser" in the command line and watch the magic happen.
    Now type bbupdater -f *.fls -e *.eep and watch how the firmware will be loaded into the flash.

    7. You should now be able to have all your hardware working again, just need to unlock using your choice of app.



    Tried this but failed half way through :(
     
  12. elgregro macrumors newbie

    Joined:
    Nov 28, 2007
    #12
    i just bought my iphone and it is unlocked. i have tmobile on it. i already know about it being locked if i update the phone... so that means i cant get the latest itunes on it.

    my question is: can i use the older version so that i can put my music into the ipod? i have version 5
     
  13. OW22 macrumors 6502

    OW22

    Joined:
    Sep 3, 2006
    Location:
    Dublin, Ireland
    #14
    The guys won't have an unlock until apple releases the NEXT firmware update. So you will have to wait until apple release 1.1.3 to unlock 1.1.2. Its all to do with the new bootloader I'm afraid.....
     
  14. ricmat macrumors newbie

    Joined:
    Nov 29, 2007
    #15
    I guys!


    I'm new here, so hi for all of you!

    Here is my issue:

    I bought an iPhone unlocked v1.0.2(1C28) - 04.01.13_G.

    Everything worked fine till now, when I was sync a video from iTunes to iPhone and when all ended the ipod app just went dead! all that appears when I tap iPod is "No Content" and when i connect it to itunes it says i have to restore it.

    So, my question is, may i restore it without loosing the unlock? or if i perform the unlock will it lock again to AT&T?



    any advices?



    Thank you guys!
     
  15. elgregro macrumors newbie

    Joined:
    Nov 28, 2007
    #16
    so i guess there is no answer to my question? ive looked all over online for hours. there is no way i can use my opod on my tmobile unlocked iphone 1.1.1 correct?

    does anybody know anything? please:(
     

Share This Page