iPhone upgrading from 4.2.1 to 4.3.3

Discussion in 'Jailbreaks and iOS Hacks' started by Zedero, Sep 3, 2011.

  1. Zedero macrumors newbie

    Joined:
    Jul 7, 2011
    #1
    Hello all, I recently got a iPhone 4 GSM. So I want to set it up and stuff. I am not super sure how to upgrade from my version that came with it (4.2.1) to 4.3.3 so I can jailbreak and stuff. Can anyone please provide me with a guide or something? I keep getting errors when I do it and I changed some lines in the hosts file and still nothing. Please help me, thanks.
     
  2. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #2
    if you don't have blobs you can't upgrade to 4.3.3 use tiny umbrella to check.
     
  3. Zedero thread starter macrumors newbie

    Joined:
    Jul 7, 2011
    #3
    I just got my iPhone, and no I don't have blobs, TinyUmbrella was being dumb, and couldn't save them. I do have restore files I downloaded from some places for 4.3.3. But I ran them, and I got an error. Then, I tried to change host permissions but still no.
     
  4. KentuckyHouse macrumors 68020

    KentuckyHouse

    Joined:
    Jan 29, 2010
    Location:
    Lexington, KY.
    #4
    The point labman was making was this...you CAN'T upgrade to 4.3.3 now. No matter what you do, you CAN'T. Tiny Umbrella can only save the blobs of a firmware that's currently being signed by Apple. So you're only option is to upgrade to 4.3.5 right now. Once Apple releases a newer OS, they stop signing the old version and unless you have the blobs of that older firmware, you can't upgrade or downgrade to it.

    And blobs (or shsh's) are unique to each phone, so even if you have the blobs for 4.3.3 from another phone, it won't work on your phone. I'm sorry to say, but I think you're out of luck.
     
  5. Zedero thread starter macrumors newbie

    Joined:
    Jul 7, 2011
    #5
    FML. :(

    Well, what are some differences between the two updates?

    I will keep 4.2.1 until untethered is released.
     
  6. Ali. macrumors member

    Joined:
    Jul 2, 2011
    Location:
    New Zealand
    #6
    You know you can have an untethered jailbreak for 4.2.1, right?
     
  7. budgynana macrumors member

    Joined:
    Nov 28, 2010
    #7
    zedero, 4.3.3 was the last untethered jb and there will be no more untethered jailbreaks until ios5 hits - a full jailbreak for 4.3.4 or 4.3.5 now will reveal the exploits apple for to fix in ios5 (therefore delaying or blocking future jailbreaks) so nobody is gonna bother until at least ios5 lands.

    as it stands, like ali said, you can do an untethered jailbreak on your 4.2.1 right now. from personal experience greenpois0n will probably be the easiest to use so there you go.

    in the meantime... about tinyumbrella, if it ain't working you'll need to go into the options and uncheck the cydia option. once you've sorted out why it's not currently working, any time apple issue an update (even a beta) go and get the new tinyumbrella (there'll be a new version to match apple's releases) and run it again to make sure you aren't left behind with your blobs.

    and lastly, you may want to try ifaith and see if it can pull the current blob from your phone directly (so that would be 4.2.1 but nothing else). it should work, saving the blob i mean, but you should be made aware that some people are reporting problems with the blobs that are saved using ifaith. having said that, if i were in your shoes i'd run it just in case.
     
  8. lokerd macrumors 6502a

    lokerd

    Joined:
    May 2, 2010
    Location:
    Beaumont
    #8
    I have 4.2.1 currently on Phone and Pad1.

    I have gotten behind on IF I should update. I have SHSH from every version released (I have been good about updating it), including 4.3.3 and even 4.3.1 through .5 and for 5.0b1-.6.

    So, I see that 4.3.3 is the highest for untethered jailbreak.

    I have done the tethered business, and it is ok. Any reason to get to .4 or .5 if I am willing to do tethered on my iPad? It doesn't really leave the house, so it is ok if it is tethered.

    Last time I checked, it wasn't worth upgrading to 4.3.1 on my iPhone. What about 4.3.2 or .3? I don't use it as a phone...only as a 3g device (with iPad sim) for mobile computer and hotspot.

    Thanks!!
     
  9. Zedero thread starter macrumors newbie

    Joined:
    Jul 7, 2011
    #9
    Actually guys, I found a guide video to update to 4.3.3 instead of the latest so I think I am going to try that and see if it works.
     
  10. budgynana macrumors member

    Joined:
    Nov 28, 2010
    #10
    lokerd, lots of people are still using 4.2.1 and if i weren't on 4.3.3 that's where i'd be right now. if it ain't broke.....

    i don't know what the differences are feature wise between these (except for the fix with the tracking/location thing which is a big deal to me) but some people reported battery problems compared to 4.2.1. 4.3.3 battery drain is ok, i think. as for 4.3.4 and 4.3.5... those are definitely mostly security fixes that also happen to block jailbreaking so they're pretty pointless - you can perform the same fixes with cydia apps without losing the 4.3.3 jailbreak.

    zedero, that shouldn't work. you need apple's permission (via shsh blobs) to restore/update and as you do not have the blobs and they are no longing issuing them for 4.3.3 then you will be stuck with an error message again. this is the whole crux of shsh blobs. your phone/itunes will throw up an error if it cannot get the blobs it needs. once they're gone, they're gone. and you've told us already that you didn't get them so don't expect that video to magically help you do the impossible.
     
  11. Tech Elementz macrumors 6502

    Joined:
    Jul 7, 2011
    #11
    Why can't the OP just jailbreak on the current firmware he is on?
     
  12. Invincibilizer macrumors 6502a

    Invincibilizer

    Joined:
    Aug 18, 2011
    #12
    Exactly I've been reading the thread and the OP should just JB since it is available unless there are some functions in 4.3.3(nothing comes in to my mind though) that aren't in 4.2.1.
     
  13. IrishVixen macrumors 68020

    IrishVixen

    Joined:
    Jun 20, 2010
    #13
    Except that once you start the upgrade process and get to a verification error, which the OP did before he ever even posted, you often can't go back to the firmware you were previously on, right? Unless, of course, you have blobs for that firmware. We get plenty of people posting here with that issue, and the advice is always the same--you're stuck with current firmware--so I assumed that was the case here. Anyone please do correct me if I'm wrong.

    When I upgraded, I actually chose to go to 4.2.1 over 4.3.3, as 4.3.3 users were reporting too many overall issues and specifically problems with preserved basebands. If you can get to it, the 4.2.1 redsn0w JB is nice and stable. The only thing I'd like from 4.3.3 is the ability to redownload music from iTunes. Other than that, there's not much difference.
     
  14. Ali., Sep 4, 2011
    Last edited: Sep 4, 2011

    Ali. macrumors member

    Joined:
    Jul 2, 2011
    Location:
    New Zealand
    #14
    During the restore process for 4.2.1 you come across error 1013 which simply means that the baseband failed to update. Just need to run greenpois0n again to kick the device out of recovery loop. Afaik you can still upgrade to later firmware versions and back again but your baseband will update, so it would depend if OP relied on an unlock or not...which is unlikely since there isn't an unlock for 03.10.01 baseband anyway.

    It will still be possible to restore back to 4.2.1 from 4.3.x firmware if he runs iFaith to capture the 4.2.1 shsh from the device if he hasn't already got it before updating.
     
  15. awadeee macrumors 68020

    awadeee

    Joined:
    Jan 21, 2011
    Location:
    Viper City
    #15
    Just jailbreak 4.2.1 with Greenpoison. Problem solved!
     
  16. adun79 macrumors newbie

    Joined:
    May 7, 2012
    #16
    Sorry to bump bring this thread up again.

    My problem: I have a 3GS jailbroken on 4.2.1 with 6.15.00 and I want to upgrade to 4.3 or newer.

    On the main page of Cydia it says SHSH 4.1, 4.2.1, 4.3, 4.3.3, 4.3.5, 5.0.1, 5.1. I also tried pulling .shsh files from the phone with tinyumbrella and I got files for those version.

    Can someone tell me if it's doable and to point me to some tutorials?



    Much appreciated
     
  17. BlueRaider macrumors regular

    Joined:
    Mar 2, 2012
    #17
    It's doable, you need a copy of Redsn0w or Sn0wbreeze, the 4.3.3 (if that's the one you want to use) .ipsw, and then just build a NO_BB firmware with Redsn0w or Sn0wbreeze and restore to it in iTunes. There are 10Million tutorials for how to do this if you will google them, don't be lazy!
     
  18. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #18
    iClarified.com has tutorials
    Look backward to 3GS with firmware 4.3.3
     
  19. adun79 macrumors newbie

    Joined:
    May 7, 2012
    #19
    Well, I did it. For those interested here's how:
    I had my blobs saved in Cydia, then I saved them on my pc with tinyumbrella.

    I checked them with redsnow and only the last 2(5.0.1 and 5.1) had APticket valid

    Downloaded the 5.0.1 firmware

    Built a custom one with redsnow. Pwned the phone and tried to update and got 3194error. Then started tinyumbrella and saarted the TSS server or what's its name. Got error 1015 (i think)

    I built then a new custom firmware with snowbreeze and used the 5.0.1 blob that I had on my drive, did that thing with the TSS server again and it worked

    But it's tethered or semi. When the phone goes off I have to boot i with redsnow. But when I restart it with Cydia i don't have to

    Thanks for the replies and cheers
     

Share This Page