iPhone v1.1.3 soft update results in DFU mode & errors 1603/1604. Help!

Discussion in 'Jailbreaks and iOS Hacks' started by musicabrutal, Jan 30, 2008.

  1. musicabrutal macrumors newbie

    Joined:
    Jan 30, 2008
    #1
    FYI, I'm using OS 10.4.11

    Okay, so I previously was working on a Jailbroken v1.1.2. I updated last night, using the new soft v1.1.3 jailbreak. Some small bugs, but nothing major. It seemed like it was working okay - until about 6 hours ago when I decided to try power-cycling the iphone to see if it would clear up some of these bugs.

    It booted back up into DFU mode. Bummer. So, when I got home, I plugged the phone in, and tried to launch iNdependence to kick the phone out of DFU mode. No dice. (I even tried plugging it into a PC to use iBrickr - but iBrickr doesn't recognize that the phone has been plugged in)

    Both v1.3.1 & v1.3.2b, when I launch the app, give me a message that reads:
    "Failure
    Error registering callbacks from iPhone"

    Here are the steps that got me to where I'm at:
    1. OTB v1.1.2 iPhone.
    2. Downgraded to v1.1.1
    3. Used jailbreakme.com TIFF exploit to get installer
    4. Installed OKTOPREP
    5. Re-updated to jailbroken v1.1.2
    6. Last night (2008.01.28), I installed the soft firmware update to v1.1.3
    7. Some small bugs were happening... i.e.:
      • No edge connectivity
      • Some 3rd party apps from installer were not showing up - or installing
    8. I power-cycled the phone, and it went into DFU mode
    9. Plugged in the iphone, and tried to launch iNdependence to boot the phone out of DFU mode... but I got the above error message window immediately upon opening the application.
    10. I tried to restore the iphone to v1.1.1, v.1.1.2, or v1.1.3 firmware... it gave me either error message 1603 or 1604, and doesn't finish the process.
    11. I tried uninstalling itunes, and reinstalling both 7.5 & 7.6 - same results
    12. I also tried running both the itunes restore - and iNdependence from a different user... but no luck there either


    Any suggestions? Any help is hugely appreciated. Thank you SO MUCH in advance...
     
  2. bellinghammond macrumors newbie

    Joined:
    Jan 30, 2008
    #2
    same here

    just did the Dev Team 1.1.3 upgrade yesterday...all seemed well....24 hours later i'm stuck on the "plug usb cable into Itunes" screen on my iphone.

    is this a time delayed hack bomb?
    I've been attempting all sorts of trips back into time (including Itunes 7.3.2) No Luck.
    No ideas.:(
     
  3. polishmacuser macrumors 6502a

    polishmacuser

    Joined:
    Jan 17, 2007
    Location:
    Los Angeles
    #3
    how baout not hacking the phone till the sdk comes out or unless you need it for unlocking purposes. Apple has got us in a trap i swear the deeper we go into these firmware jailbreaks the more headaches bleh. Well I know independence wont kick it out if your in 1.1.3 and downgrading and doing it all over is the only option i see.
     
  4. bellinghammond macrumors newbie

    Joined:
    Jan 30, 2008
    #4
    i did find this....

    http://hackint0sh.org/forum/showthread.php?t=15849

    it's a guide to activating in 1.1.1
    The key was to use the -latest- Independence 1.3.2 beta

    even then all i have is a glorified ipod...Anysim 1.1 wouldn't work.
    Probably a baseband thing. (& i also couldn't get back to 1.0.2 & start ALL over)

    wish i could get the phone part of iphone back (T-Mobile)
    if anyone can tell me that trick i'd be much obliged...
     

Share This Page