iPhone waiting for approval

Discussion in 'iPhone' started by Cache, Oct 25, 2016.

  1. Cache macrumors regular

    Joined:
    Sep 12, 2007
    #1
    I updated to the latest version of iOS 10 today. After the update I was asked to sign into iCloud and my phone (6s) is now "waiting for approval". It says to go to another device which is logged into iCloud to grant approval, but how do I do that exactly?

    I've got two iPads, another iPhone (5s) and a MacBook Pro, but I cannot find any option to approve my 6s from these devices.
    --- Post Merged, Oct 25, 2016 ---
    Here's a screenshot.
     

    Attached Files:

  2. beernut macrumors 6502

    Joined:
    Jan 13, 2016
    #3
    is at least one of those other devices signed on to the same icloud account?

    if one of the are signed on, what do you get when you go to setting--> icloud --> keychain on that device?
     
  3. Cache thread starter macrumors regular

    Joined:
    Sep 12, 2007
    #4
    Thank you both for the replies. I don't really get what is meant by "go to keychain". None of my devices use keychain, i.e. it's turned off in the iCloud settings (refer to screenshot), nor am I prompted to use a 4 digit security code when I do turn it on.
     

    Attached Files:

  4. beernut macrumors 6502

    Joined:
    Jan 13, 2016
    #5
    what about on your macbook?
     
  5. Cache thread starter macrumors regular

    Joined:
    Sep 12, 2007
    #6
    After turning my macbook on it immediately asked for my iCloud password, which I entered. Afterwards I went to the iCloud settings and tried turning Keychain off in there as well (it was on and said 5 devices were asking for approval). When trying to uncheck the box, I am prompted to enter my password. I do so correctly though the checkbox remains checked. I then signed out of iCloud and right back in. Now it says it's waiting for approval too! Wtf!
     

    Attached Files:

  6. beernut macrumors 6502

    Joined:
    Jan 13, 2016
    #7
    sign out of icloud on all your devices and sign in again on only one and set it up from there.

    or, what happens when you click the "can't approve"?
     
  7. Cache thread starter macrumors regular

    Joined:
    Sep 12, 2007
    #8
    Alright, I'll try to sign out of iCloud on all my devices. If I click "can't approve" I get a message saying my Apple ID will be blocked for 24 hours (screenshot).
     

    Attached Files:

  8. Cache thread starter macrumors regular

    Joined:
    Sep 12, 2007
    #9
    Just an update for anyone who has a similar problem. I've contacted Apple support and the issue is now resolved. What I had to do was log in with my Apple ID through my browser and turn off two step verification. Afterwards sign out of iCloud with my iPhone. After signing back in everything was working fine again.

    Keychain was indeed the culprit. I have never used keychain and it's turned off on all my devices, but after updating my iPhone the two step verification was forcefully turned on. Anyway, for some reason this caused the issue I was having.
     
  9. Bazooka-joe macrumors 68000

    Bazooka-joe

    Joined:
    Mar 12, 2012
    Location:
    Swindon, England
    #10
    Yep that's what I had to do. 2FA works well across Apple devices but its a pain in the neck because it sometimes asks for two devices to authenticate a request and if I don't have a second device with me at the time.....
    I disabled it in the end.
     
  10. Thor_1 macrumors 6502a

    Joined:
    Sep 18, 2016
    Location:
    Texas
    #11
    I had my family add an extra number, in case they are having issues with their number or account.
     
  11. beernut macrumors 6502

    Joined:
    Jan 13, 2016
    #12
    good info. thanks for following up :)
     
  12. pat2ick macrumors newbie

    pat2ick

    Joined:
    Aug 13, 2017
    #13
    Thank you for sharing your solution. I had this problem several times before and today, after the update, i decided to look for someone who has solved this problem. Thank God you shared your solution. Two thumbs up for you bro.
     

Share This Page