Iphone Wi-Fi Connectivity issues

Discussion in 'iPhone Tips, Help and Troubleshooting' started by KatateKid, Aug 2, 2008.

  1. KatateKid macrumors newbie

    Joined:
    Aug 2, 2008
    #1
    My iPhone wont connect to my home Wireless Network.

    I recently had to get a new router and it is a modem/router combination.

    My iPhone used to work, but now it says it is connected, but when i try to get on a web page, it says it cant connect to the server. my wii has the same problem
     
  2. unknowng macrumors member

    Joined:
    Jan 17, 2008
    #2
    I'm having the same problems. I just got my phone and this problem is really pissing me off. Mine does the same thing. It says I'm connected to the access point with good signal, but it doesn't display the page. Sometimes it works and then it just randomly stops. It's driving me nuts.

    G
     
  3. unknowng macrumors member

    Joined:
    Jan 17, 2008
    #3
    The crazy thing is that if I use the remote app the wifi is working fine, but if I use mail or safari, it just sits there trying to connect. It doesn't seem to be a problem connecting to the access point and working in the local network, but trying to access the internet outside the network that doesn't want to work. Just an observation.

    G
     
  4. Kai Chen macrumors newbie

    Kai Chen

    Joined:
    Jul 12, 2008
    Location:
    East Bay
    #4
    Have you guys try checking your firewall to make sure that ip address is being allowed to surf.
     
  5. unknowng macrumors member

    Joined:
    Jan 17, 2008
    #5
    I assume you mean the firewall on my router? I don't have any IP restrictions. I've got about ten devices in my house that connect to the internet and they are all working fine. One thing I tried is changing my DNS servers and giving my iPhone a static IP address. The static IP address didn't fix it, but so far changing the DNS servers to Open DNS has worked. Of course that could change at any point. I'll keep you updated.

    Greg
     
  6. HarryAndAGuitar macrumors member

    HarryAndAGuitar

    Joined:
    Jul 21, 2008
    #6
    I have the same problem as all of you except mine is a little different. My iPhone connects to my home wifi PERFECTLY but when i go to one of my friends houses, i try to connect to their wifi and it says i have a really good signal but it won't like work. It only seems to be with Wifi at other people's houses. When i'm on 3G, Edge etc..... it is ok. Can anyone suggest anything? Thanks.
     
  7. unknowng macrumors member

    Joined:
    Jan 17, 2008
    #7
    Does your friend have restrictions based on MAC address? After you set up the connection, you could try changing the DNS servers. Mine has been flawless all day. The OPEN DNS server addresses are 208.67.222.222 and 208.67.220.220.

    Greg
     

Share This Page