iphone wifi email issue

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Stately, Nov 17, 2009.

  1. Stately macrumors 6502a

    Stately

    Joined:
    May 14, 2008
    Location:
    NYC
    #1
    Hey MR community. I have an issue with my iphone receiving email over wifi using my router. . it doesn't. I cannot send email either. This started happening a while back. I can connect to the internet just fine and with a strong connection, so I do surf but I cannot get email. The strange thing is if I connect to anyone else's router, the email comes through just fine and I can send as well. Does anyone have a solution? There must be something I'm overlooking.
     
  2. Stately thread starter macrumors 6502a

    Stately

    Joined:
    May 14, 2008
    Location:
    NYC
  3. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #3
    Might be nice, since you bothered to post, to say how you fixed it so it might help others with the same problem.
     
  4. Stately thread starter macrumors 6502a

    Stately

    Joined:
    May 14, 2008
    Location:
    NYC
    #4
    Why certainly, since you asked so nicely. It really wasn't anything big at all, it was a minor oversight. I was initially connected to my router. As anyone knows, a password is required. However, once your phone is connected, you no longer need to type it in again. Somehow when my phone accidently connected to someone else's router it severed my connection to some degree. So somehow I could still surf on the web using my router but I could not get my mail, it was weird. I had to treat my router as foreign. I told my phone to forget this network, this way it would totally sever the connection as opposed to partially. I then reconnected and it asked me for my password again as though I was forming a new connection. This solved the issue.
     

Share This Page