iPhone WiFi Issues, please help!!

Discussion in 'iPhone' started by EarlofCroydon, Aug 4, 2010.

  1. EarlofCroydon macrumors member

    EarlofCroydon

    Joined:
    Jun 4, 2010
    #1
    Both my iPhone 3GS's (Switched from Black to White) have had this problem so it is definitely my router. Whenever I leave the house and come back I have to go and select 'BT HomeHub QRNT' from the available WiFi list on my iPhone because it defaults back to BT Openzone. I don't have to re-enter the password but it is quite annoying. Also from time to time my iMac will drop off the internet and I have to turn the router off/on for it to connect again. Very bizarre!

    Thanks :apple:
     
  2. saving107 macrumors 603

    saving107

    Joined:
    Oct 14, 2007
    Location:
    San Jose, Ca
  3. EarlofCroydon thread starter macrumors member

    EarlofCroydon

    Joined:
    Jun 4, 2010
    #3
    One from our Phone/TV/Internet provider. BT (British Telecoms), it's probably unheard of in America is there some kind of setting on the iPhone?
     
  4. f4780y macrumors 6502

    f4780y

    Joined:
    Jul 21, 2009
    Location:
    Troon, Scotland
    #4
    BTHomeHub

    It happens because your phone will prefer one wireless network over another. If you connect to a BTOpenZone hotspot out of the house, then when you get back home it sometimes decides to prefer the openzone network your hub broadcasts, over your own personal homehub network (it will see them at equal strengths, but over than I don't know how it decides what it prefers)
    Make sure you "forget this network" for the OpenZone before you disconnect from it, then connect to your homehub and it should become the default. Of course, if you regularly connect to openzones outside you will probably run into this alot! I know I do.
    Hope that helps.
     
  5. EarlofCroydon thread starter macrumors member

    EarlofCroydon

    Joined:
    Jun 4, 2010
    #5
    I've forgotten the network, hope that sorts it, thanks! Welcome to the forum
    :apple::D
     

Share This Page