iPhone wifi: Unable to join the network "linksys"

Discussion in 'iPhone' started by MacVault, Nov 27, 2010.

  1. MacVault, Nov 27, 2010
    Last edited: Nov 27, 2010

    MacVault macrumors 65816

    Joined:
    Jun 10, 2002
    Location:
    Planet Earth
    #1
    I'm not sure this is specific to my iPhone because my Macbook also has same issue. But it's driving me nuts on my iPhone right now. Here is the issue...

    Sometimes my iPhone works fine on my wifi network and then out of the blue it will just swich to 3G and if I try to connect it back to the wifi it will say Unable to join the network "ssid". And sometimes it asks me to reenter the pre shared key, sometimes not. Usually I can get it to reconnect by turning the wifi off on the iPhone for a while, like maybe 20-30 minutes, then turn it on and much of the time it will then work.

    I suspect it's an issue in the Darwin code, common on both the Macbook and iPhone, because I've used this Linksys WRT54GL running DD-WRT 2.4 for years and this issue has only popped up in the last 6-8 months with my Macbook and now I'm really noticing it on my newly purchased iPhone 4. Noticed issue running both iOS 4.1 and 4.2.

    Issue does not seem to show up on my 3 Windows laptops. Only apple devices so far. And I have not noticed this issue when I use my iPhone 4 on my employer's Cisco wifi network.

    Why would these devices work fine for hours or days and then suddenly be unable to connect / reconnect??
     
  2. whsbuss macrumors 68040

    whsbuss

    Joined:
    May 4, 2010
    Location:
    SE Penna.
    #2
    Sounds like you may need to update to a new router. 802.11n is where you want to be anyway.
     
  3. xlii macrumors 68000

    xlii

    Joined:
    Sep 19, 2006
    Location:
    Millis, Massachusetts
    #3
    You could go to linksys's user forum and see if others are having the same problem. That's what I did and found out that the linksys router I had just bought was a piece of junk with lots of people having the same problems I had. I lived with it for a few months and finally fixed it by buying a dlink dir-655. A router that has worked so well I ended up buying one for my mom & my wife's mom.
     
  4. RoboCop001 macrumors 65816

    Joined:
    Oct 4, 2005
    Location:
    Toronto, Canada
    #4
    I get that sometimes too. I just reboot the router and it works fine afterward. Noticed that the Linksys at work has the same problem and the issue is solved by rebooting it.

    I'll probably not buy linksys anymore lol
     
  5. macsrcool1234 macrumors 65816

    Joined:
    Oct 7, 2010
    #5
    It's not the router, it's Apple. Of all the things they can do, they simply cannot get wifi working properly. Every one of their products had either had or currently has an issue with wifi.
     
  6. MacVault thread starter macrumors 65816

    Joined:
    Jun 10, 2002
    Location:
    Planet Earth
    #6
    That's what I'm thinking. My iPhone and Macbook both have this issue. I'm sharing my wifi with my neighbor who has an older dell laptop - they say they never have an issue. My two older toshiba windows laptops from work - also never an issue. But my Macbook and iPhone = issue is very evident and seems to be getting worse.
     
  7. rwilliams macrumors 68040

    rwilliams

    Joined:
    Apr 8, 2009
    Location:
    Durham, NC
    #7
    I agree. None of my Windows machines ever has a problem with my wireless router, but our two MacBooks, iPhones, and my iPod Touch routinely have trouble connecting. Apple just seems to do a really poor job of implementing Wi-Fi.
     

Share This Page