iPhone will not enter DFU mode throug redsn0w 0.9.6b5

Discussion in 'Jailbreaks and iOS Hacks' started by dreamingoflions, Dec 5, 2010.

  1. dreamingoflions macrumors newbie

    Joined:
    Sep 6, 2010
    #1
    I got my iphone replaced today and need to jailbreak & unlock it in order to be able to use it in the UK. I am trying to use the iPhone2,1_4.2.1_8C148a IPSW

    It is an Iphone 3GS, iBoot-359.3, 4.2.
    Whenever I run redsnow it works fine until the window which should be asking me to hold the power button for 3, then with home for 15, and then home button for 10 seconds.

    Well I get to that screen but I hold the power button for about 2 seconds and it moves on to the next window. Then it will try to install but just tells me there is an unexpected error and to retry.

    Whenever I plug in my iphone it says it is a phone in recovery mode and asks me to restore it. What can I do to jailbreak & unlock it???
     
  2. ulbador macrumors 68000

    ulbador

    Joined:
    Feb 11, 2010
    #2
    DFU mode has no visible signs, the phone will have a black screen, if you get the "Connect to iTunes" message right away, you are in restore mode. Try again.
     
  3. QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #3
    Make sure your phone is off before starting the DFU mode process. If you follow the prompts EXACTLY it will work every time.
     
  4. dreamingoflions thread starter macrumors newbie

    Joined:
    Sep 6, 2010
    #4
    Well I restored it and tried again. The issue is the screen doesn't wait long enough for me to complete putting it into DFU mode. It starts the countdown and after 3 seconds it switches to the jailbreaking window...
     
  5. dreamingoflions thread starter macrumors newbie

    Joined:
    Sep 6, 2010
    #5
    I turn it off before I open redsnow. Should I be turning it off right before I am putting it into DFU mode?
     
  6. QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #6
    As long as it's off before you start putting it into DFU mode it doesn't matter. Try following RedmondPie's instructions just in case you're missing something.
     
  7. modojojo macrumors newbie

    Joined:
    Aug 20, 2007
    #7
    I'm having this same exact issue now, It's as If redsnow dosen't let u complete the DFU sequence. As soon as I hit the power button on the edge, redsnow tries to install the jailbreak for the device before It's In DFU mode.:mad:
     
  8. dreamingoflions thread starter macrumors newbie

    Joined:
    Sep 6, 2010
    #8
    Had the same problem. What helped was restarting my Macbook each time that happened. Possibly try that?
     

Share This Page