iPhone will not let me restore

Discussion in 'iOS 5 and earlier' started by awcomix, Oct 12, 2011.

  1. awcomix macrumors newbie

    Oct 12, 2011
    I got impatient and downloaded a beta version of iOS 5 yesterday. Every thing was going fine until I got to a screen that said,
    'this device is not registered as part of iPhone developer program...'

    From this point I tried to restore, and got a message the software was not available. I have tried again today now that it has officially released and at first it look like it downloaded the new ios5. However I still get the same developer warning screen. and can't go any further.

    Is there any way to erase this previous developer settings and start fresh with witha full restore? Could I jailbreak it, wipe everything and then restore?

    I have an iphone 4 16gig, and being in Australia I'm 99% it's GSM

    See screen grabs for exact error messages

    Attached Files:

  2. grapes911 Moderator emeritus


    Jul 28, 2003
    Citizens Bank Park
  3. awcomix thread starter macrumors newbie

    Oct 12, 2011
    Thanks Grapes! This worked a treat! Very relieved!

    I will definitely not be doing anything like this in future!!


Share This Page