iPhone with 2 email accounts-sending problem for second account

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Le Big Mac, Jul 20, 2012.

  1. Le Big Mac macrumors 68020

    Le Big Mac

    Joined:
    Jan 7, 2003
    Location:
    Washington, DC
    #1
    iPhone 4S, with all updates.

    I have two gmail accounts, primary and secondary. I have both accounts set to use smtp.gmail.com, with password authentication for each account.

    Primary account can send just fine using SMTP. Secondary account cannot send through it's "own" server (i.e., secondaryemail@gmail.com) and sent messages failover to the primary account server (primaryemail@gmail.com). Of course, that means recipients see the email as coming from the primary account, which is totally contrary to the reason I have it.

    Settings for smtp are identical, except for username and password. I can send using the secondary account in Mail on my Mac, using that server, with messages showing properly (i.e. from secondaryemail@gmail.com).

    Any ideas what's going on?
     
  2. aamirshah macrumors newbie

    Joined:
    Jul 14, 2012
    #2
    delete the secondary email then again create secondary account then check if its working or not and you can also setup your email server as pop.gmail.com. Try both then tell me the results.
     
  3. Le Big Mac thread starter macrumors 68020

    Le Big Mac

    Joined:
    Jan 7, 2003
    Location:
    Washington, DC
    #3
    I've deleted account a couple times and no dice.

    Just tried pop.gmail.com as outgoing server.

    No dice.

    I should add that when I add the smtp server it does the verification on the iphone and I get all checkmarks, so it's not a password or port issue (I think).
     

Share This Page