iPhone wont charge, Broken home button, Speakers don't work

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Mickeysheehan, Mar 3, 2012.

  1. Mickeysheehan macrumors newbie

    Joined:
    Mar 3, 2012
    #1
    Hey guys, I really need help, I got this iPhone fairly new from a good friend about a week ago, and some lady left her baby in the car seat, ON THE HOOD OF HER CAR! I ran and caught it as it slid off the back, But got my iPhone, and my feet ran over -.- Unfortunately, Money is an issue in my family, and i'm not looking to spend tons of money to fix it, or get a new one. The iPhone only had the bottom ran over (From the Home Button, down.) So basically, the whole bottom doesn't work. It isn't mangled or shattered, but it looks as if the back of the plastic iPhone casing, has been forcefully slid to the right. I can give you info about it more, I just really need help, I was so happy when I got this, and I only had it less than a week, Thanks!
     
  2. Mickeysheehan thread starter macrumors newbie

    Joined:
    Mar 3, 2012
    #2
    Please guys, I'm really trying to fix this, I just need to know how. I can't reset it, because the home button doesn't work, and I can't restore it, because it's not recognized by a computer, or any charger
     
  3. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #3
    Wirelessly posted (iPhone 4s: Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    Hop on eBay and order a complete back it includes battery speaker dock port etc and also order a new digitiser including frame. Shouldnt cost the earth
     
  4. Mickeysheehan thread starter macrumors newbie

    Joined:
    Mar 3, 2012
    #4
    Solved! For free!!!

    Wow, I can't believe this worked, I was just under the impression that this iPhone was hopeless, so I decided to take it apart properly just to learn more about the intestines of an iDevice, I noticed after I took of the screen (By unscrewing the 2 bottom screws by the Speaker/Charging Port) There were little tabs that snapped into place, Such as a button. There was 5 of them under the screen, and I noticed the one labeled number 4 Was not in place, I just simply pushed it down with my thumb, Heard it snap into place, Put it back together, And now it works! It charges, The Home button works, Speakers work. In fact, It seems faster than it was. I hope this helps other people like me. Thanks for your help.
     

Share This Page