iPhone won't connect properly via WiFi

Discussion in 'iPhone Tips, Help and Troubleshooting' started by vega07, Oct 1, 2007.

  1. vega07 macrumors 65816

    Joined:
    Aug 7, 2006
    #1
    I'm at my new apartment and have been trying to connect to my friend's router with no success. The iphone sees the connection and connects to it properly with an IP address and etc., but safari, mail, weather, and everything else requiring an internet connection doesn't work. The router is a DI-614+.

    Further, I am able to connect to it just fine with my macbook and everything works.

    Perhaps I have to configure the ports???

    edit: google search works, but that's it. I'm baffled. :confused:

    edit#2: actually, it just works sometimes...like 1 out of 10 clicks, the page will load.
     
  2. Macsterling macrumors regular

    Macsterling

    Joined:
    Sep 24, 2007
    Location:
    Dallas
    #2
    Wirelessly posted (iPhone: Mozilla/5.0 (iPhone; U; CPU like Mac OS X; en) AppleWebKit/420.1 (KHTML, like Gecko) Version/3.0 Mobile/3A109a Safari/419.3)

    I'm having the same problem and posted something earlier and I have yet to have a response. It seems to me that no one likes helping the newbies around here.
     
  3. dj420118 macrumors regular

    Joined:
    May 17, 2006
    #3
    I am having a similar problem...it connects to my network and then after one page load the wifi disconnects completely and all of a sudden it doesn't seem to find ANY wireless networks. Five minutes later it finds them again. I called apple and they told me to send it in. I just sent the phone via FedEx today and they sent me a loaner phone for free.
     
  4. vega07 thread starter macrumors 65816

    Joined:
    Aug 7, 2006
    #4
    lol, just be patient. someone will help us. is your problem exactly mine? which router are you using?

    it seems like only certain websites will work like orb.com, google, yahoo. or maybe it's just that I got lucky with these pages because they loaded.
     
  5. vega07 thread starter macrumors 65816

    Joined:
    Aug 7, 2006
    #5
    yours seems like a hardware issue. my problem is not, because I can connect via wifi fine everywhere else but just not this one connection.
     
  6. Macsterling macrumors regular

    Macsterling

    Joined:
    Sep 24, 2007
    Location:
    Dallas
    #6
    Wirelessly posted (iPhone: Mozilla/5.0 (iPhone; U; CPU like Mac OS X; en) AppleWebKit/420.1 (KHTML, like Gecko) Version/3.0 Mobile/3A109a Safari/419.3)

    I'm using apples base station. Their latest one. It shows up in my network settings and it is connected with all bars but when I try to surf the web it only shows Edge.
     
  7. Marvin Martian macrumors newbie

    Joined:
    Oct 9, 2007
    #7
    me too

    hi folks

    Help

    Me too- I can connect ok in coffee shops and at home with my linksys router but after serving up the first or second page, my iPhone seems to forget its ip address and just hangs on the next request. Of eventually times out and throws a server can't be fount message.

    Renewing the lease does not seem to help. If I forget the connection and go back to edge, all is fine.

    Setting problem??????

    Thanks in advance

    Marv
     
  8. dakooga macrumors newbie

    Joined:
    Sep 24, 2007
    #8
    OK this might help - it from a different world but weirdly might be applicable.

    My Nintendo Wii was having problem connecting to my router (a Linksys WRT-54GS with the DD-WRT firmware). Whatever I tried it connected, worked briefly then did nothing (whilst still thinking it was connected).

    Same with my Nintendo DS.

    I found the solution on an obscure website I can't remember and it's not on Nintendo's site.

    Anyway I digress. Access your Wifi settings on your router, if it's a good one you'll have some extra controls usually in the advanced section.

    Look for pre-amble. Set it to Long (not auto or short).

    That fixed it for me and my Nintendo and DS and my iPhone works just fine with it.

    Let me know how you get on.

    DaKooga
     

Share This Page