iPhone won't connect to 3g after leaving wifi

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Mecmecmec, Apr 27, 2010.

  1. Mecmecmec macrumors newbie

    Joined:
    Apr 10, 2010
    #1
    Hi All,
    I have my iPhone 3gs connecting to my wifi at my house. When I leave my house it says "3G" at the top of the phone but it won't connect to any websites. Only after I restart the phone will it work. I've even tried to manually turn wifi off & it still doesn't connect to 3G (or Edge for that matter). 3G is enabled & I have plenty of 3G signal. I can make & receive calls however, just no email/internet.

    Any ideas?

    Thanks!
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Mine used to do that a while back on 3.0.1 or earlier 3.+ firmware versions.
    Are you updated to the latest firmware and carrier updates?
     
  3. Mecmecmec thread starter macrumors newbie

    Joined:
    Apr 10, 2010
    #3
    Yea, I'm updated to the latest versions for both.
     
  4. twonga macrumors member

    Joined:
    Sep 28, 2007
    #4
    ive got the same problem!

    on 3.1.3 jailbroken with spirit!

    3g/edge will sometimes only work if i restart the iphone, anyone manage to find a fix?
     
  5. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #5
    Reset network settings. If that doesn’t work, I’d restore and try a rejailbreak (or not jailbreak).
     

Share This Page