iPhone Won't Connect to Ad Hoc Network

Discussion in 'iPhone Tips, Help and Troubleshooting' started by djmorice, Jul 1, 2009.

  1. djmorice macrumors newbie

    Jul 1, 2009
    I'm trying to connect my iPhone 3g running 3.0 firmware to an ad hoc network on my Macbook Pro running OS 10.5.7.

    After I setup the ad hoc network on my computer, the ssid shows up on my phone fine. But, when I try to connect to the ad hoc network my 3g icon in the top left corner of the phone never changes to the wifi icon. So it basically never connects.

    I really just want to be able to use the iTunes remote app on my iPhone without a "real" wifi connection.

    Is there anything special you need to do to connect your iPhone to an ad hoc wifi connection? Has anyone done this?
  2. polarbreeze macrumors newbie

    Dec 26, 2008
    Can't ad-hoc to iPhone

    Unfortunately I can't help you but I have exactly the same problem. Identical in all respects - same 3.0 - 10.5.7 - same symptoms. Did you find a solution? Can anyone else help? Thanks!
  3. ian.maffett macrumors 6502


    Aug 1, 2008
    Did you set up the connection on your laptop properly? You have to manually configure it as ad-hoc (identical SSID) and try to connect to both at the same time - laptop first, then iPhone. I haven't used it for this purpose but I am able to do it regardless.
    Just verifying...
  4. whshep macrumors newbie

    Dec 18, 2009
    Try going into airport mode, then re-activating the wifi.

    In Settings, turn Airplane Mode On. Wifi will automatically go off (as will the phone).

    Click Wi-Fi, then choose your ad-hoc network. It should work now.

    I'm submitting feedback on this to Apple.
  5. historydoll macrumors newbie

    Nov 14, 2006
    same problem, none of the fixes work

    I have tried this. I have tried everything suggested in every forum I can find--except putting my iPhone in the freezer, which has been seriously suggested but which I am really really reluctant to do. It works, on alternate Tuesdays following a full moon. in other words, just enough to make me keep trying. But most of the time, it doesn't. I can set up the ad hoc network on the desktop just fine, and the iPhone can see it, and tell me it's connected to it, but the indicator on the top left remains stubbornly fixed on 3G no matter what I do. If I try Bonjour, it just can't see the iPhone at all.

    As many people have said before me, these problems--and other, somewhat less annoying, wi-fi related ones--began with the upgrade to 3.1.2. Please tell me someone has finally figured out how to fix this particular problem
  6. hooplehead macrumors member

    Feb 25, 2008
    Exact same problem here. My ad hoc worked fine for years until about a week ago. It worked through an iPod Touch, and now my new 3GS, then it just stopped working. All I can remember changing was some automatic Windows Update around the same time. Otherwise, I didn't install any programs or apps in the days before or following the problem.

    Strangely enough, if I turn my firewall off, the iPhone wifi works. I even started a thread to that effect, as I thought it was a firewall issue.

    Please post if anyone gets a fix!
  7. yoman macrumors 6502a


    Nov 11, 2003
    In the Bowels of the Cosmos
    Same problem here

    I hope someone comes up with a solution.
  8. jackd360 macrumors newbie

    Dec 19, 2010
    I am Jesus

    I have found a way to do it
    1) Set up the ad hoc network on the mac/PC
    2) Go to settings on the iphone and enable flight mode
    3) Go to wifi on the iphone (in settings) while still in flight mode and select the ad hoc network
    4) Wait 20 seconds and next to the plane in the top right corner of the screen a wifi symbol will appear (still on the iphone)
    5) You're good to go

    This works
    I believe I am Jesus

    Please comment to say it works ;)
  9. edwardswa macrumors newbie

    Feb 29, 2012
    Dallas; Ireland; the sky...
    You're indeed a savior (on this issue)

    This totally works! I had experienced hours of frustration trying unsuccessfully to get the OfficeTime iPhone app to recognize my MacBook Air so that I could synch OfficeTime between MacBook and iPhone. OfficeTime suggested the ad hoc network, but until now to avail. I have found no one else who has figured out this workaround. Thanks a million! ESW...


Share This Page