iPhone won't connect to wifi anymore

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mikora7, May 5, 2011.

  1. mikora7 macrumors member

    Jul 5, 2007
    A couple weeks ago I started having problems connecting to any wireless network. My network shows up in the list of wifi networks but when I put in my password, it says "Unable to join the network "nw2" Dismiss." I have an Airport Extreme router and I had it set to WPA2 personal. I changed it to WPA ~ no luck. I changed it to WEP and no luck. Now I have set it to no password at all and it STILL says it cannot connect and to dismiss.

    I have hooked it up to my computer and restored it back to factory settings. There is now nothing on it, not even the games my kids bought. Still, it won't work. What do I do now?
  2. mikora7 thread starter macrumors member

    Jul 5, 2007
    I can add that I checked with a technology instructor who compared her iPhone to mine and noticed that even when she manually put in her schools internet specifications, it still didn't access the internet. It can see the wifi, but when you select that little blue arrow to the right of the network name, there are no settings showing at all. Of course, on her phone, everything shows up. Apparently my phone can see the network but fails to connect.

    Do I need to go to the Apple Store and see what the genius's there can tell me?
    Or, because it's nearly 2 years old, do I just need to upgrade to a new phone and tell them that this one is defunked?
  3. cmojones, May 6, 2011
    Last edited: May 6, 2011

    cmojones macrumors newbie

    May 5, 2011
    Have you tried resetting your network settings? To do so go to Settings>General>Reset(all the way down at the bottom)>Reset Network Settings

    This will remove saved networks that you currently have on your phone, but this is kind of what you want in this case.

    Or have you tried restoring your iPhone to factory defaults using iTunes? I would back it up first, so you don't lose contacts and all of that other jazz while restoring.

    I would reset the network settings first and use the restore as a last ditch effort.
  4. DeaconGraves macrumors 65816


    Apr 25, 2007
    Dallas, TX
    Sounds like you've already done a full restore, but I would try the Network Settings refresh suggested above too.

    If that doesn't work, time to take it into the Apple Store. If you don't have Apple Care, see how much a repair will cost. Depending on how desparately you need wifi, it might be worth waiting for an iPhone 5 (September hopefully).
  5. mikora7 thread starter macrumors member

    Jul 5, 2007
    I reset network settings first. When that didn't work, I hooked it up to the computer and tried a full restore to factory settings. When that didn't work, I tried resetting the network again, so I guess I've done all I can do on my own. I'll look into the cost of repairs. I'm pretty sure I don't have Apple Care so we'll have to see what the best option is. Thanks!
  6. rocketboy66 macrumors newbie

    Aug 11, 2011
    Finally a fix. But not a pretty one.

    I had the same problem. The wifi network appears on the iPhone, and it claims to be connected, but cannot be used as the iPhone doesn't get allocated a valid IP address on the network. I have an iPhone 4 and an extreme base station. After many resets and following suggestions on various forums, nothing worked.
    It appears that the problem is that the Airport Extreme is failing to correctly allocate a private IP address to the iPhone using DHCP - an automated connection protocol. No idea why this isn't working, it ought to be straight forward - possibly a bug in the latest iPhone iOS?
    The way I solved it was to use the Airport Utility to change the connection setting on the airport Extreme from automatic allocation of IP addresses, to only allocating a range of IP addresses from 2 to 200.
    On the iPhone I then change from DHCP to Manual and set the IP address to xxx.xxx.xxx.201 (where the x's are the private IP address range chosen by Airport Utility). If needed, another device could be set to 202 etc.
    All very ugly, sorry, but at least it works if nothing else does. Best of luck. I hope Apple finds out why it is happening and fixes it, it seems a lot of people are also struggling with this.
  7. mikora7 thread starter macrumors member

    Jul 5, 2007
    Quick question for you... since this is an area I've never messed with, if I do it, will our Wii and other computers/devices still find the wireless internet or would I have to go in and manually configure each device?
  8. kcgunner macrumors member

    May 3, 2009
    Anyone find a fix yet

    I've tried everything in this forum to fix this to no avail. I'm on iOS 5.0 beta 6 and I can't downgrade to 4.3.x. I've tried assigning direct IP addresses, resetting network settings. Restoring from old backups, all to no avail. I still get that stupid "Cannot connect to network." So so stupid. I literally went to bed and everything was fine. Woke up and had no WiFi. I did nothing while I was sleeping. Jesus technology Christ! Anyone been able to fix this??
  9. ryanaaaah macrumors newbie

    Aug 24, 2011
    if it happened suddenly, i'm afraid it's the problem of the wifi element, the cost for change this part is around $50 to $60, good luck
  10. yanki01 macrumors 68030


    Feb 28, 2009
    i just had this happen to me and i had to put it in manually. worked for me after that?
  11. mikora7 thread starter macrumors member

    Jul 5, 2007
    Nothing worked for us. My husband gave up trying and is getting me a new phone. He might transfer his number to my iphone (his phone is really old) but he doesn't use any internet stuff ever so he doesn't care if it works. :eek:
  12. luckystephens macrumors member


    May 26, 2007
    This worked for me assuming you have an Airport Extreme.

    After some work trying out different settings I have finally solved this.

    1) Make sure that the settings of your Airport Extreme are in mixed a/b/n mode

    2) Open Airport Utility

    3) Select Upload Firmware from the BaseStation menu

    4) If you current version is 7.5.2, click Upload Firmware

    5) Select 7.5.1 from the pop up menu

    6) Restore Firmware

    After this is complete, you should be able to use your iPhone with the Airport Extreme. The latest firmware is buggy and does not allow iPhones with the latest iOS to connect.
  13. mikora7 thread starter macrumors member

    Jul 5, 2007
    Ah, wish I'd been able to try this a couple weeks ago. I finally gave in and bought a new phone. :(
  14. angelinaS31 macrumors newbie

    Sep 30, 2011

Share This Page