iPhone wont join my WiFi

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Burton8219, Jul 11, 2008.

  1. Burton8219 macrumors 6502

    Joined:
    May 12, 2007
    #1
    Hey guys I just got a black 16 gig iphone and when I get home and try to join my WiFi connection the phone says "Unable to join Network 'Blah Blah'" Can someone give some suggestions on what to do for this. I will try and reset my router, but I wanna see if there are any other suggestions.
     
  2. Joe23 macrumors 6502

    Joined:
    Sep 14, 2007
    #2
    Are you using WPK-PSK for the authentication? It's case sensitive - took me a while to work that out first time around :rolleyes:
     
  3. Burton8219 thread starter macrumors 6502

    Joined:
    May 12, 2007
    #3
    no, i dont have passwords on it
     
  4. J@ffa macrumors 6502a

    J@ffa

    Joined:
    Jul 21, 2002
    Location:
    Behind you!
    #4
    Did you have the original iPhone?
     
  5. Burton8219 thread starter macrumors 6502

    Joined:
    May 12, 2007
    #5
    Yes I did and the WiFi worked fine on it and it is currently allowing me to make this post.
     
  6. Mitch1984 macrumors 6502

    Mitch1984

    Joined:
    May 16, 2005
    Location:
    Telford
    #6
    A common mistake is that sometimes the router has a button on it that you need to press to stick it into pairing mode, have a look for one of them.
     
  7. Burton8219 thread starter macrumors 6502

    Joined:
    May 12, 2007
    #7
    No I don't have one and have never needed to press a button on my router to connect to my wireless network
     
  8. Balistix macrumors newbie

    Joined:
    Jul 11, 2008
    #8
    I'm having the same problem with connecting my new 3G iphone to my wifi network at home. It connects perfectly with other wifi networks but does not want to connect to mine regardless of whether it is secured or unsecured!
     
  9. Jase2008 macrumors newbie

    Jase2008

    Joined:
    Jul 9, 2008
    Location:
    Scotland UK
    #9
    when i set mine up yesterday, it didnt find my network for a while. Although it seemed to find every network around the area. But the second time i tried it, it found and logged on no problem.

    :confused:
     
  10. glxyjones macrumors regular

    glxyjones

    Joined:
    Jun 29, 2007
    #10
    Having the same problem here. I have an old iphone and upgraded to 2.0 and my ability to connect to my wifi has been very sporadic.

    Last night I was able to get it to connect by manually typing in my wifi information/password via "other network." However, this morning, not even that will work. I constantly get the "Unable to Join Network *****" error message.

    I can't imagine it can be anything other than the 2.0 upgrade because I never had this problem before.
     
  11. lnferno macrumors 6502

    Joined:
    Jun 19, 2008
    #11
    Yeah, I just got the new iPhone 3G yesterday and I'm having a similar problem. I've setup the WiFi access to connect to my WPA Linksys wireless router at home. It will connect and then sporadically lose it's connection even though I'm within a few feet of it. :confused:
     
  12. spathi macrumors newbie

    Joined:
    Mar 7, 2003
    Location:
    Sunshine Coast, Queensland, Australia
    #12
    Hi,

    I noticed some of you mention you have a Linksys router?

    I had the exact same problem and found upgrading the firmware resolved the issue.

    Please take a look at a post I wrote regarding this here for this and another solution.

    I hope this helps a few of you out.

    Cheers,

    Josh
     
  13. jamieboss1 macrumors newbie

    Joined:
    Jul 15, 2008
    #13
    Linksys

    I also had problems with my linksys router and iphone 3g up until about 2 minutes ago. I updated the router's firmware and then enabled wpa and wpa2 under security settings and the phone is finally working on my home network!
    Hope that helps.
     
  14. lnferno macrumors 6502

    Joined:
    Jun 19, 2008
    #14
    I'm still having the same problem. I didn't need to update the firmware as it already had the latest version. WPA/WPA2 is definitely enabled.

    When you guys setup your WiFi connection, are you specifying WPA or WPA2 on your iPhone?

    My SSID isn't set to broadcast, but that shouldn't matter.
     
  15. GeeeWhiz macrumors newbie

    Joined:
    Jul 18, 2008
    #15
    iPhone wont join my WiFi

    I'm having the same trouble here at home. There are 2 new 3G iphones here. One logs in maybe 1 try in 3 and the other logs in maybe 1 try in 20.

    At home I use WPA. A laptop and a desktop computer upstairs connect to my wifi with no problem.

    There doesn't seem to be any problem using the iphones with unencrypted wifi in the mall.

    Yesterday I went into Apple and they set up a WPA wifi for me and both iphones logged in just fine.

    Any ideas for trouble shooting will be appreciated.
     
  16. ichii macrumors 6502

    ichii

    Joined:
    Sep 20, 2006
    #16
    I'm also having the same problem, my 3g iPhone connects fine, but my brother's 2g iPhone wouldn't connect to wifi after 2.0 update. Also if I call Apple would I get a coffin to send the iPhone in or would I have to bring it to a retail store to get it fixed? The closest store is about 1-1/2hr away
     
  17. lnferno macrumors 6502

    Joined:
    Jun 19, 2008
    #17
    Holy cow, I finally figured out what the deal was. In my linksys configuration, for the Encryption Algorithms, I had to select "TKIP+AES". Before I just had TKIP. I just changed it, now it's working like a charm for me! WHEW!
     
  18. ichii macrumors 6502

    ichii

    Joined:
    Sep 20, 2006
    #18
    after I changed the setting, the iPhone detects the router, then I enter in the key, then it join then it won't see the wifi. I hope 2.01 fix this bug :mad:
     
  19. Minimoose 360 macrumors 65816

    Minimoose 360

    Joined:
    Jul 7, 2008
    Location:
    NY
    #19
    Weird. I think it definitely has something to do with updating the router. If you have an archaic Linksys you may have to update....I have a brand new Linksys 802.11n UltraRange Plus blah blah router and it works just fine with BOTH my original iPhone and my iPhone 3G...
     
  20. ichii macrumors 6502

    ichii

    Joined:
    Sep 20, 2006
    #20
    I have the 54gv2 one the black linksys one. It worked before the update, so I don't think it's the router.
     

Share This Page