Iphone wont leave email on server

Discussion in 'iPhone Tips, Help and Troubleshooting' started by academy, Oct 26, 2010.

  1. academy macrumors newbie

    Joined:
    Oct 26, 2010
    #1
    Hi all,

    I am loving my new iphone 4 but am having a problem with the email settings. My isp is ntlworld (now virgin media) and my network is t-mobile uk. I have set the iphone up with the incoming as pop.ntlworld.com amd smtp.t-email.co.uk and can send and receive email ok but it does not arrive on my mac. They both have the delete from server option set to one month. However whatever one is turned on is the only one it arrives on. Never had this problem with my 8900 or 9700 so I am assuming its not a isp problem

    Any ideas?
     
  2. androiphone macrumors 65816

    Joined:
    Dec 13, 2009
    #2
    use imap instead, it is way more stable and maintains a sync on both sides.

    also in the setting under pop it has a drop down of what to do with the messages, delete, keep in inbox or archive.

    but as I say just use imap that way when you 'delete' emails on the phone they archive in the server and are then available under 'all mail' on the device
     
  3. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #3
    that's because you are using a POP account... you could try to set it up as an exchange (if it supports it) or IMAP account to solve your problems...
     
  4. CSMchris376 macrumors regular

    Joined:
    Mar 13, 2010
    Location:
    Illinois
    #4
    I'm not sure, but I think you have one of the settings reversed. When looking at the settings for my mail on the iPhone 4, the only choice that corresponds to "remove after one month" is when to remove deleted messages, not when to delete from the server. The only choices for delete from server are never, seven days, when removed from inbox. I have my deleted messages remove set to one day, that way after one day your trash folder is emptied. I have delete from server set to never, so I can get the mail on my computer as well. I have a POP account.

    In response to the other poster, not every ISP provides the option for IMAP accounts, the only way to get around that is to forward the mail to somewhere that does, such as GMail, etc. That is an option for the OP if desired. Create the GMail account as IMAP, then forward the mail from the ISP.
     
  5. academy thread starter macrumors newbie

    Joined:
    Oct 26, 2010
    #5
    Thanks for the comments so far,

    The thing is it worked perfectly with my bb9700 so whats the problem with the iphone 4 and pop mail?
    I have the "delete from server" option set to never and have tried after seven days and one month but it just deletes immediatly. But its the same from my mac, if i recieve it on the mac it wont go to the phone, yet when I was using a blackberry it worked with the mac really well.
     
  6. androiphone macrumors 65816

    Joined:
    Dec 13, 2009
    #6
    yes virginmedia email runs off gmail so it definately has IMAP, the setting I ment for pop was in the webmail interface not on the iphone,

    so log onto the webmail and go settings>pop/imap settings> then under pop select either keep in inbox or archive.

    but imap is 1000x better than pop so under the same settings path in the webmail under pop settings there is imap settings click on configure your client and then just follow the general settings for one of the other clients as the iphone isnt listed. make sure imap access is enabled and after that disable pop access
     
  7. academy thread starter macrumors newbie

    Joined:
    Oct 26, 2010
    #7
    ok thanks for that I will contact virgin about the settings tomorrow, bugs me that the 9700 worked fine with it though, I am sure I am missing something obvious
     
  8. rich8rr macrumors newbie

    Joined:
    Nov 14, 2010
    #8
    academy, I don't know if you have sorted the problem but this is how I resolved exactly the same issue after changing from Bold 9700 to iPhone 4 and using an iMac.

    On your mac web client goto preferences>accounts>(select) account>advanced

    From here uncheck 'remove copy from server after retrieving message'

    This worked for me.

    Hope this helps.
     

Share This Page