iPhone won't let me restore; device not eligible for requested build?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by IverTHPS2, Jan 17, 2011.

  1. IverTHPS2 macrumors newbie

    Joined:
    Jun 23, 2009
    #1
    I decided to change my iPhone password from numerical to text-based... which, disastrously, has resulted in me forgetting said password. This shouldn't be much of an issue in theory, but I'm greeted with a lovely error message every time I try to restore the iPhone.

    After clicking "restore," iTunes takes around a minute before I receive a message indicating the following:

    "The iPhone "iPhone" could not be restored. This device isn't eligible for the requested build."

    So, how can I restore my iPhone despite this message popping up after every attempt?
     
  2. NathanA macrumors 6502a

    Joined:
    Feb 9, 2008
    #2
    Not enough information.

    What model of iPhone?

    What is its current firmware/OS version on the phone?

    What version of iTunes?

    MacOS or Windows?

    I've never heard of this happening, but I suspect (although I don't know for certain) that iTunes may have an old cached copy of the last firmware version you either restored or upgraded to lying around somewhere, and it's not the latest available version (so, something pre-4.2.1). For some reason, iTunes is using this version to fulfill your restore request rather than realizing there is a newer version available to download. Apple won't "sign off" on restores for anything older than 4.2.1, and when you try to restore to 4.1 or older, you will get the exact error message you described.

    Why would iTunes not realize that there is a newer version? Not sure because, again, I've not heard of this happening before. But I suppose that either something could have been wrong with your internet connection at the time, or with Apple's update servers, or perhaps you have a really ancient version of iTunes installed and you need to update IT first.

    Other than when people are purposefully trying to downgrade their iOS on their phone, the only other time that I've heard of people getting this error message is when they try to do a restore to a phone that they are not supposed to be in possession of (like, say, a prototype model). In those cases, Apple probably bricked the phone remotely, and then instructed the update servers to not sign off on restores for ANY firmware version for that phone's ECID/serial number. For example, see this web page: http://www.fixyourthinking.com/2009/06/supposed-iphone-3gs-prototype-on-ebay.html

    -- Nathan
     
  3. IverTHPS2 thread starter macrumors newbie

    Joined:
    Jun 23, 2009
    #3
    Sorry!

    It's an iPhone 4 and, while I don't know the exact firmware, it's older than the one that introduced a free version of "Find My iPhone." I'm using iTunes 10.0.1 on a Mac.

    I guess I'll try to update to 10.1.1 but, if that fails, I have no idea what I can do short of taking it to the Apple store.
     
  4. NathanA, Jan 17, 2011
    Last edited: Jan 17, 2011

    NathanA macrumors 6502a

    Joined:
    Feb 9, 2008
    #4
    Okay, are you using the phone either unlocked or jailbroken? Or do you just use it "stock"? In other words, do you have anything to lose by upgrading to the latest software (the one that gives you Find My iPhone for free)?

    If you don't have anything to lose, then, yes, I would first update iTunes, and if that doesn't work, then try following these steps:

    1) Visit http://www.felixbruns.de/iPod/firmware/
    2) Scroll down, and near the bottom you should see "Download iOS 4.2.1 via direct links here:"
    3) Click on the link underneath that heading for "iPhone 4" to download the firmware to your computer (Safari will probably dump it in your Downloads folder).
    4) Plug in your phone, and launch iTunes.
    5) Select your iPhone within iTunes, and this time, hold down your Option key while you click on the Restore button.
    6) A file selection box will pop up when you do this. Navigate over to your Downloads folder and look for a file called "iPhone3,1_4.2.1_8C148_Restore.ipsw" -- select that one.

    What we've just done is manually downloaded the latest firmware for your phone, and then told iTunes where to find it. If it isn't able, for some reason, to grab the latest version itself, this should work around that problem.

    Hope this helps,

    -- Nathan
     
  5. IverTHPS2 thread starter macrumors newbie

    Joined:
    Jun 23, 2009
    #5
    That worked perfectly; thank you so much for your assistance!
     
  6. zemukas macrumors newbie

    Joined:
    Oct 9, 2011
    #6
    iphone 3gs error

    when i tried to update my 3gs iphone at itunes at the end of the update appeared the error 1015 and my iphone got blocked with the itunes sylmbol to connect to the pc.. i tried to fix it with snowbreeze and tinyumbrella and now my iphone at itunes apears the error " device not eligible for requested build".. can anyone help me? my iphone is 3gs and i have a macbook pro.
    i'm getting insane with this =/
     
  7. misterxdonut macrumors newbie

    Joined:
    Oct 9, 2011
    #7
    What iOS software are you running? Most likely you are trying to restore to a software version that Apple stopped signing for, meaning you can't restore to anything except the current version of iOS that's out. But we need more info on your device to know for sure.
     
  8. bman1209 macrumors newbie

    Joined:
    Nov 16, 2009
    Location:
    Canada
    #8
    so all you had to do was update iTunes?
     
  9. zemukas macrumors newbie

    Joined:
    Oct 9, 2011
    #9
    misterxdonut iphone 3gs

    i'm using the mac os x version 10.6.8. .. about my iphone i don't know anything about it i bought it friday and it was working..when i connected it to itunes the problems came..sorry for my poor english =/ but i would really apreciate your help my friend x) my iphone is dead at this time

    ----------

    my mac is up to date and itunes is also updated to the most recent version
     
  10. zemukas, Oct 10, 2011
    Last edited: Oct 11, 2011

    zemukas macrumors newbie

    Joined:
    Oct 9, 2011
    #10
    iphone 3gs

    i dont know how to check the iphone software because it is "frozen"

    can anyone help?
     
  11. zemukas macrumors newbie

    Joined:
    Oct 9, 2011
  12. mephistus macrumors newbie

    Joined:
    Oct 15, 2011
    #12
    I am having the same issue on my macbook pro. I have all the updates and now I have the latest itunes. BUT when i go do it from my PC, no problems at all. I have never been able to restore from my macbook pro. i just uploaded the IOS5 on my Iphone 4 and it works good.
     
  13. acoyney macrumors newbie

    Joined:
    Nov 15, 2011
    #13
    iPhone 4 won't let me restore

    I downloaded the software and followed your instructions, but this didn't work, do you have any other suggestions?
     
  14. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #14
    You know that this post is almost a year old and since then Apple stops signing 4.2.1 firmware. Right?

    You can't restore to any firmware Apple stops signing. So, if you want to following this instruction, you must ignore the 4.2.1 and go with the latest fw.
     
  15. vetri911 macrumors newbie

    Joined:
    Nov 12, 2010
    Location:
    Madras, India
    #15
    How to restore old firmware to an iPhone

    Just out of curiosity . Does anyone know how to load old versions of iOS that Apple has stopped signing to an iPhone ?
     
  16. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #16
    Depending on which Iphone do you have. It is possible with 3G, not possible with 3GS and Iphone 4.
     
  17. LaWally macrumors 6502a

    Joined:
    Feb 24, 2012
    #17
    No. Suggest you [re]read post #4. He updated the firmware on his iPhone using iTunes.

    Whoa! Did not see how old this thread was. Sorry.
     
  18. Terrin, Feb 7, 2013
    Last edited: Feb 7, 2013

    Terrin macrumors 6502

    Joined:
    Apr 5, 2011
    #18

    First download Text Wrangler (free).

    Then on the Go menu of the Finder (OSX) select go to folder. Type in: /etc/

    Then go to the host file. Right click and open the file using Text Wranger. If you see an entry like: 74.208.10.249 gs.apple.com, put a # in front of the 74.208.10.249 gs.apple.com so it looks like # 74.208.10.249 gs.apple.com.

    Save the host file. You might have to type in your password.

    Then go back to iTunes and try to do the update again.
     

Share This Page