iPhone won't restore after I jailbroke it

Discussion in 'Jailbreaks and iOS Hacks' started by iphonemaniac211, Jun 12, 2011.

  1. iphonemaniac211 macrumors newbie

    Joined:
    Jun 12, 2011
    #1
    Hey

    ive read a few threads with people with nearly the same problem as me...but mine seems to be slightly different as in, none of their fixes are working for me..
    Basically
    My iPhone has been jailbroken for months now and for some reason, iTunes decided to upgrade the OS yesterday. It failed, leaving me with that 'plug into itunes' screen..so I did, and it told me my iPhone was in recovery mode..so I tried to restore it...But it would fail, and I would get the error 1603. I have also followed all the steps on the apple website related to this error code, itunes/os of my laptop is up to date..

    Ive literally tried everything..and no hope?
    Is there any fix for this or is my iphone dead?
     
  2. stewart715 macrumors 6502

    Joined:
    Oct 2, 2008
  3. iphonemaniac211 thread starter macrumors newbie

    Joined:
    Jun 12, 2011
    #3
  4. Knowlege Bomb macrumors 603

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
    #4
    Did you modify the hosts file?

    My phone errors out every restore if I don't do this.
     

Share This Page