iPhone won't restore on Mac, will on Windows

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mikekirk, Jun 7, 2010.

  1. mikekirk macrumors member

    Joined:
    May 26, 2010
    #1
    I've got a really weird problem. I've had to restore my iPhone 3GS recently after some, er, tinkering, but the restore just will not work on my iMac. The progress bar on the phone gets to around 2/3rds of the way complete, and then everything stops. No errors, no crashes, nothing else happens.

    If I plug the phone into my netbook which has Windows 7 on it, the restore works flawlessly. Plug it back into the Mac, run the restore and I get the same.

    I've tried deleting the OS installation file from my Mac so that it downloads a new copy from Apple, I've also tried DFU mode, both with the same result.

    Does anyone have any ideas?
     
  2. mrbossman macrumors newbie

    Joined:
    Jun 8, 2010
    #2
    I had same problem.

    I had wifi sync installed on my mac. Uninstall it and the restore process will work ok - no idea why.
     
  3. mikekirk thread starter macrumors member

    Joined:
    May 26, 2010
    #3
    Oh, I think that might still be running on mine! I'll take it off, thanks for the tip.
     

Share This Page