iPhone won't save pictures to camera roll

Discussion in 'iPhone Tips, Help and Troubleshooting' started by wrathofhawk, Aug 13, 2009.

  1. wrathofhawk macrumors newbie

    wrathofhawk

    Joined:
    Aug 13, 2009
    #1
    Hi, I noticed earlier while messing around with the camera the pictures wouldn't save to the camera roll. When I go into the folder, it shows as if I never took anything. I went online and looked for a resolution and a few websites had threads dating back to 2007 on how to fix this, saying I need to backup my stuff, do a hard reset on my iPhone instead of restoring on computer. I don't know if this will work though and am a little worried of trying because I WILL lose all my sms history, notes, contacts by doing this "method" if anyone knows what I'm talking abuot. And because of what firmware people had back then I don't know if it'll work for 3.0.1. I was wondering if anyone has had the same problem and found a way to fix it w/o restoring or losing anything I have on my iphone now.

    By the way I did reset my iphone a few times and did the home screen + sleep button technique and nothing worked.
     
  2. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #2
    Just do a restore to 3.0.1, and then restore from a backup. You won't lose anything. :)
     
  3. wrathofhawk thread starter macrumors newbie

    wrathofhawk

    Joined:
    Aug 13, 2009
    #3
    Thats the thing from what I read I have a "corrupt system file" on my iPhone and when I back up my phone and do a hard reset on the phone itself I have to ignore restoring from backup at first. I have to go back and take a picture with my phone THEN restore for some reason. I don't know if that means I'll lose my contacts,notes,sms history and such because I've never tried it but thats the only way, doing a regular restore won't work according to about 5 websites that have posted the same method.
     
  4. wrathofhawk thread starter macrumors newbie

    wrathofhawk

    Joined:
    Aug 13, 2009
    #4
    I don;t know why I didn't do this earlier, I took a 5 second video and it appears in my camera roll, but pictures still don't. Anyone else have any suggestions?
     

Share This Page