iPhone won't sync music with iTunes

Discussion in 'iPhone' started by yanksno1, May 8, 2016.

  1. yanksno1 macrumors newbie

    Joined:
    Oct 11, 2012
    #1
    So I'm trying to sync my music from my iTunes (12.3.3) to my iPhone 6S Plus (9.3.1) and it just flat out won't. I'm using a Macbook Air 10.11.4. I've tried deleting all the music on my iPhone, but now when I select Sync Music (and have my Entire music library selected) all the songs show up in the audio part of the storage bar. So if I click apply, it looks like it's syncing the music at first but then it goes through it and only syncs the U2 album (and the songs aren't in the storage bar obviously). If I delete my music again, it will delete the U2 album, but the same thing happens when I try to select my entire music. I've posted screenshots (I'm Zach by the way) of what happens below.

    [​IMG]

    [​IMG]

    [​IMG]

    Do you guys have any suggestions on what might be going on here?
     
  2. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #2
    Zach,

    If you select music at the top left near movies do you see a list of all albums and songs or do you see albums with a cloud icon at the top right of each album?
     
  3. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #3
    I notice he has family sharing on.
    Would this relate to the issue?
     
  4. yanksno1 thread starter macrumors newbie

    Joined:
    Oct 11, 2012
    #4
    No cloud icon next to each song, it's all on my Macbook Air.

    Where do you see that setting? I'm totally missing it. I wouldn't think it should matter, but I can try turning it off to see if that's the issue.
     
  5. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #5
    I have seen a small house icon at the left of that music icon, so.
     
  6. yanksno1 thread starter macrumors newbie

    Joined:
    Oct 11, 2012
    #6
    Nope, doesn't look like that's the issue. Disconnected the server and the same thing happens. I'm really at a loss. Tried doing a hard reset on the phone, upgraded to 10.11.4. Here's some more screenshots with the server disconnected.

    [​IMG]

    [​IMG]

    [​IMG]
     
  7. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #7
    Maybe you can consider using utilities like iExplorer to manually delete iTunes library on your device, and try syncing again.
    It's free for this purpose.
     
  8. yanksno1 thread starter macrumors newbie

    Joined:
    Oct 11, 2012
    #8
    Haha! I found out what the issue was. So after turning the iTunes server off and reloading iTunes, then it was showing the icon for not found media next to each song. So deleting what was there and re-scanning it worked! Thanks for the help and pointing me in the right direction!
     
  9. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #9
    Congratulations! :)
     

Share This Page