iPhone X’s Max keeps disconnecting from s4 watch

Dmal99

macrumors 6502
Original poster
Sep 29, 2012
492
168
This all started when I noticed that now playing was missing and I realized that my xs Max keeps Bluetooth disconnecting from my watch.

I’ve done all the resets and everything. Anyone else getting this ?
 

tehfunk

macrumors newbie
Jun 19, 2009
10
3
For what it's worth, I'm experiencing the same issue. iPhone XS Max + Apple Watch Series 4.

I *think* it's something related to bluetooth on the XS Max, because I've seen others complaining about similar flakiness. Hoping an iOS update will fix it...12.1 didn't.

This all started when I noticed that now playing was missing and I realized that my xs Max keeps Bluetooth disconnecting from my watch.

I’ve done all the resets and everything. Anyone else getting this ?
 

maxchile

macrumors member
Nov 6, 2018
93
8
Santiago, Chile.
When you say disconnect, you mean the red icon in the apple watch? ( the red iphone icon )? I am using the beta ios 12.1.1 beta 3 and issue not resolved.
 

bhodinut

macrumors regular
Jan 31, 2013
129
82
I'm running WatchOS 5.1.1 on my S2 and my S4. The S4 always seems to disconnect whereas the S2 never loses connection with my XS Max.
 

mertkutluk

macrumors member
Mar 10, 2009
31
8
You think maybe is the S4, and not the iphone xs max?. I used the S4 with a iphone 6 and work it perfect.
Hi maxchilie!

I saw your messages in Apple support pages, iMore and now here :)

I'm from Turkey, and I have exact same problems with you.

1-Connection drops in 1-2 meter with my Series 4 Watch
2-No Bluetooh animation appears whenever I open my AirPods' cases
3- Some problems with Wi-fi

Did you find any solutions?

Thanks.

Mert.
 

maxchile

macrumors member
Nov 6, 2018
93
8
Santiago, Chile.
Hi maxchilie!

I saw your messages in Apple support pages, iMore and now here :)

I'm from Turkey, and I have exact same problems with you.

1-Connection drops in 1-2 meter with my Series 4 Watch
2-No Bluetooh animation appears whenever I open my AirPods' cases
3- Some problems with Wi-fi

Did you find any solutions?

Thanks.

Mert.
Hi ! nop nothing yet, i updated ios 12.1.3 beta 3 , and didn’t resolve my issues :(
 

minimo3

macrumors 6502
Oct 18, 2010
443
256
I have a 6s and a month old AW S3 with 5.1.2. Today it disconnected in the middle of the day. Turning on/off Bluetooth, rebooting etc didn’t fix it. Only a reset erase all settings, unpair/repair fixed it. I hope this doesn’t become a regular occurrence
 

maxchile

macrumors member
Nov 6, 2018
93
8
Santiago, Chile.
I have a 6s and a month old AW S3 with 5.1.2. Today it disconnected in the middle of the day. Turning on/off Bluetooth, rebooting etc didn’t fix it. Only a reset erase all settings, unpair/repair fixed it. I hope this doesn’t become a regular occurrence
Hi you reset the iphone or the AW?
[doublepost=1546996521][/doublepost]
I'll be on apple store Thursday, I'll let you know. I am not sure if its a widespread issue or we are the unlucky ones :(
please let me know , unfortunately i’m based in Chile and i don’t have support here :( , try to get more infortation from the apple guys about this issues and tell you are not the only one , many thanks !
 

maxchile

macrumors member
Nov 6, 2018
93
8
Santiago, Chile.
Have you tried updating using itunes?

There is a newer version of IOS 12.1.2 than the OTA update (at least on 6s), with some fixes for iPhone XR, iPhone XS, and iPhone XS Max. Doesn't say anything about BT though..
https://support.apple.com/en-us/HT209084
yes i tried before like 2 moths ago, i will tried again... thanks
[doublepost=1547117828][/doublepost]
It seems like a hardware issue after all. They are providing me new unit.
hi ! and the problem resolved changing the unit ?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.