iPhone XS Max iphone Xs Max not registering charger?

gadgetgirl85

macrumors 68040
Original poster
Mar 24, 2006
3,575
97
For some reason, my iphone Xs max is not registering the charger. I have to usually pull to try plugging it in twice. Is anyone else having this issue?
 
  • Like
Reactions: QueenTyrone

M33-1

macrumors 6502
Jun 15, 2010
276
153
I have the same issue. Have to unplug and plug in twice sometimes. I have an amazon cable. I will need to try my apple cable still in the box.
 

seriouslyjaded

macrumors member
Jun 23, 2010
46
30
I’ve seen the same with a 5w and 12w apple charger and one of the powered USB ports in my Lenovo port extender “dock” will not charge even with an apple cable - never had that issue with my 6s on that port.
 

gadgetgirl85

macrumors 68040
Original poster
Mar 24, 2006
3,575
97
I’ve seen the same with a 5w and 12w apple charger and one of the powered USB ports in my Lenovo port extender “dock” will not charge even with an apple cable - never had that issue with my 6s on that port.
Me either. I feel tempted to take it back for a swap.
 

reyalP

macrumors 6502
Oct 10, 2012
325
114
I have the same problem. Plug it in while the screen is black and nothing. Unplug and and plug it back in and it works. Wireless charger works every time.
 

eric3312

macrumors 6502
Sep 17, 2012
495
204
For some reason, my iphone Xs max is not registering the charger. I have to usually pull to try plugging it in twice. Is anyone else having this issue?
I too am having this issue with my XS Max. Seems to be fussy getting the charger to register.

This kind of stupid **** makes me wonder how they’re getting away with charging 1100+ dollars for these phones. I mean come on. How long has charging technology been around?
 
  • Like
Reactions: Orangeman13

richard371

macrumors 68020
Feb 1, 2008
2,460
698
Same issue here. I'm pretty sure its a handshaking issue that's kind of random. If you leave it plugged in it will eventually connect. Sometimes 20 seconds sometimes a min or 2. I doubts its hardware.

"I have this weird issue with my Max where sometimes when I plug the charging cable in it take between 20 seconds to a minute before it detects and starts charging. It is very intermittent and is instant 99 percent of the time. When it doesn't detect the cable right away it will after a min or so. I've tried different Apple cables chargers etc, If is test it by unplugging the cable and plugging it back in 20 times its flawless. I try wiggling the cable and it does not break the connection at all. Its rock solid. I cleaned the port and its fine. The fact that its very intermittent and always start charging when it does happen without touching the phone or cable tells me it’s some sort of software issue."
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.