iPhone4 - "No Sim Installed" Error

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Reimer, Dec 7, 2011.

  1. Reimer macrumors regular

    Reimer

    Joined:
    Sep 15, 2006
    #1
    This is an iPhone4 that I've been using with a SIM card that I cut into a micro-sim myself for the past year without any issues. It was on 4.2.1 and I never bothered updating.

    I decided to give the phone to my sister. So I wiped the phone and did an upgrade to iOS 5.0.1 and popped her card in. Trying over and over again, I could not get the phone to detect the SIM card.

    I tried popping my old card back in and got the same "No SIM Installed" error again. I even tried a third SIM with the same results.

    I then did a little searching and see that it's a common problem, possibly attributed to the SIM tray.

    http://wooservers.com/20100710/fixing-iphone-4g-no-sim-installed-problem/

    I've tried using tape on the card and on the tray. I've tried applying a little more force on the tray itself. I've gone and restored 5.0.1 with no change.

    Nothing is working. I found it strange it was working with my old SIM just fine and now, all of a sudden after the upgrade to 5.0.1, it won't detect any card now.

    Any ideas? TIA
     
  2. atlanticza macrumors 6502a

    atlanticza

    Joined:
    Jul 18, 2008
    Location:
    Cape Town
    #2
    Had a similar, intermittent issue. Discovered that the sim was faulty... but in your case, odds are that there is a 'mechanical' issue with your phone. Take it to an Apple store?
     

Share This Page