iPhone4 not compatible with tiger!?!?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by cwfrederick, Jun 24, 2010.

  1. cwfrederick macrumors member

    Joined:
    Oct 7, 2008
    #1
    was it common knowledge that leopard or snow leopard was required to sync the iphone 4? i was pretty pissed when i pulled an all-nighter, waited in line for 4 hours, and then find out when i get home that i can't even sync my new phone to an OS that's only two versions back. it does however support windows vista, 7, xp home, xp professional. i put up with a lot of apple stuff like this but this just seems overly absurd, and a big fu to apple users in particular.:mad:

    (i'd get SL but my gd super drive on my white mb has gone out on me 3 times and i got sick of taking it in, and so of course my 3 years is up.)
     
  2. GimmeSlack12 macrumors 603

    GimmeSlack12

    Joined:
    Apr 29, 2005
    Location:
    San Francisco
    #2
    It just needs iTunes 9.2 doesn't it?
    EDIT: Apparently not, needs 10.5.8 or higher.
     
  3. mulletonabike macrumors newbie

    Joined:
    Oct 15, 2009
    #3
    tiger

    I had the same problem yesterday. I posted on here and just got told I should have checked before purchasing but everything I read about the phone didnt mention this at all! iphone4 supports all types of windows but no OS X!?! How is this possible? Im not a happy bunny at the moment.
    Looks like im going to have to fork out another £30 to buy Leopard so I can get my phone working!
     
  4. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #4
    i dont know what you are being so aggrivated for. it says it on the box!

     
  5. ChrisTX macrumors 68030

    ChrisTX

    Joined:
    Dec 30, 2009
    Location:
    Texas
    #5
    Not only that but in this point in the game, who still runs Tiger?
     
  6. jrcsh6 macrumors 6502

    jrcsh6

    Joined:
    Jul 1, 2008
    #6
    i ran tiger until about a week and a half ago....hah
    yea it was made clear that it required 10.5+ in specs.
    I don't know that I would have noticed though had i not wondered if my imac g5 was gonna be ok (since the new iphone is about as powerful) sure enough the g5 continues to rock! hah. leopard is as high as the power pc can go though....at some point i'm f'd and will have to buy my illusive imac (with blu ray)

    and the window support is due to the fact xp is the most used window os and the newer ones of course will be supported....and there are a TON of windows users that apple is trying to convert with iphones and ipods!
     
  7. cwfrederick thread starter macrumors member

    Joined:
    Oct 7, 2008
    #7
    i still think its total bs and a big f u to apple users. it should be a given that it works with tiger. and its kinda hard to read the box when its 5am in the morning and it hasnt been released yet. :mad:
     
  8. jrcsh6 macrumors 6502

    jrcsh6

    Joined:
    Jul 1, 2008
    #8
    not to be a jerk but i found it on the apple website the day of preordering. got a copy of leopard that wens. night. installed and got my imac opperational over the weekend and was ready by sunday night for the phone...then wens when fedex came by my office i was ready to roll. all of us with old computers need to think about this stuff. kinda like how firewire support is gone with all of the 3g phones....i've got multiple fire wire things from ipods past and lost them.

    but yea it is b.s that it's not supported! also like not supporting ipod hi-fi with new stuff. that thing is still a cool box!
     
  9. GimmeSlack12 macrumors 603

    GimmeSlack12

    Joined:
    Apr 29, 2005
    Location:
    San Francisco
    #9
    Quit whining and go buy Snow Leopard, it's $30. Tiger is 3-5 years old. You've got your money's worth.
     
  10. hzeat macrumors member

    Joined:
    Dec 8, 2009
    Location:
    Dallas
    #10
    $30? it's around $100+ off eBay...but even that is shady. i had to buy it direct from Apple, luckily they still had it...for $156 which included $16 overnight shipping.
     
  11. GimmeSlack12 macrumors 603

    GimmeSlack12

    Joined:
    Apr 29, 2005
    Location:
    San Francisco
    #11
    What are you talking about? Here:
    http://store.apple.com/us/product/MC573Z/A?fnode=MTY1NDAzOA&mco=MTc1Njg3ODQ

    There. $30.
    Believe me the "upgrade" statement is totally bogus. This is the full version.
     
  12. jrcsh6 macrumors 6502

    jrcsh6

    Joined:
    Jul 1, 2008
    #12
    oh but make sure to read the box of snow leopard....the snow kitty doesn't work on power pc. if you've got an oldie like me it's leopard for you!
     
  13. hzeat macrumors member

    Joined:
    Dec 8, 2009
    Location:
    Dallas
    #13
    ^what jr just said...i was talking on a power pc, should have been more descriptive there... as i had to get MAC OS X 10.5.6 LEOPARD... not Snow.
     
  14. What r ye doing macrumors newbie

    Joined:
    Nov 25, 2010
    Location:
    Underwater with my cat
    #14
    Actually a good amount of people still run tiger because they see no reason to upgrade because you get a new dock and wallpapers. It's the same computer nothing new.
     
  15. sherryroadcap macrumors newbie

    Joined:
    Jan 4, 2011
    #15
    My iMac won't load Snow Leopard

    What do I do now. I bought it and it won't load. My iMac is intel and only 2 years old.
     
  16. OllyW Moderator

    OllyW

    Staff Member

    Joined:
    Oct 11, 2005
    Location:
    The Black Country, England
    #16
    Then there's a problem with your iMac. Snow Leopard should install on any Intel Mac.
     
  17. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #17
    You might have to load Leopard instead.
    Sucks that Apple is doing that to their customers and wont support the i4 on older computers. Thats nonsense.
     
  18. slansh macrumors newbie

    Joined:
    Jan 6, 2011
    #18
    I spent 3 months of life ironing out all bug probs for Pro Tools 7.3, Reason, eastwest, DFH plug ins etc t be compatible with mac OSX 10.4,If apple think i,m goin t spent another 3 month updating all software t make my computer compatible with a ****in ipod they can take a hike, this products goin straight back t the shop:mad:
     
  19. woundedPumpkins macrumors newbie

    Joined:
    Jan 8, 2011
    #19
    I do.
    I am using it now as I reply to this thread. I don't see the point in fixing something that isn't broke. You would assume though that seeing as this is an apple product, they would make it compliant with every single apple pc it has ever produced. But hey, apple make billions a year, why listen to a few consumers who are peeved off???

    I am not saying it is right, far from it, I think it's BS, but I am not phased because I also have a PC that is Windows so I can sync my new iPhone to that. No biggie.

    I am just happy I read what specs were needed ... I am also trying to find a 9.2 itunes download. Apple only shows the 10.1 on its official page. On my iBook it is version 8.
     
  20. ashman70 macrumors 6502a

    Joined:
    Dec 20, 2010
    #20
    I am just happy I read what specs were needed ... I am also trying to find a 9.2 itunes download. Apple only shows the 10.1 on its official page. On my iBook it is version 8.

    Here is a link for every version of iTunes for the MAC going back to 7.3

    http://hackstor.blogspot.com/2010/02/itunes.html
     

Share This Page