iPhone4 not connecting to Internet

Discussion in 'iPhone Tips, Help and Troubleshooting' started by uptowngirl, Aug 18, 2010.

  1. uptowngirl macrumors newbie

    Joined:
    Sep 30, 2008
    #1
    Hi,

    I have been having the same problem with my iPhone 4 since I got I think it may be something to do with the way I set it up as I had the same problem with my previous iPhone.

    Often the phone just won't load up the internet whether it's safari, mail, facebook or anything else. It has a signal and says it connected but just won't load anything up.

    Has anyone else had this problem?

    I was thinking of restoring it and setting up as a new iPhone but I don't understand if I can then get all my apps and contacts back on without restoring from back up? (as I think this might be the problem, my friend who lives nearby got the phone the same day as me, set it up as new and doesn't have any internet problems).

    If anyone's got any ideas it would be great!

    Thanks
     
  2. nippyjun macrumors 65816

    Joined:
    Jul 26, 2007
    #2
    It this a problem for both cellular and wifi?

    Have you gone into settings and just reset network connections?
     
  3. uptowngirl thread starter macrumors newbie

    Joined:
    Sep 30, 2008
    #3
    It's just cellular.

    Yep, i think i've reset all settings on the phone itself.

    Thanks
     
  4. hoogen macrumors regular

    hoogen

    Joined:
    Jun 22, 2010
    #4
    the same thing is currently happening to me. did you ever figure out what the problem was?
     

Share This Page