iPhone4 restore without upgrade problems

Discussion in 'Jailbreaks and iOS Hacks' started by lordcheeto, Jan 4, 2012.

  1. lordcheeto, Jan 4, 2012
    Last edited: Jan 4, 2012

    lordcheeto macrumors newbie

    Joined:
    Jan 4, 2012
    #1
    Hi everyone.

    I have searched and tried all kinds of different things to figure out this problem I am having! I have searched this forum up and down, and all over google and I still cannot find a solution to my problem. I find things that SHOULD work, but I still can't seem to get it fixed.

    Here is what happened: I went to the AT&T store and upgraded from my iPhone 4. Now, having a pretty much brand-new iPhone 4 in my hands that is almost useless to me since the upgrade, I decide to sell it. Well, to sell it I need to wipe the information.

    I had a jailbreak running 4.3.1. I decided that to clear it would be to just erase all content and settings... I didn't know there was some kind of bug involved with doing that on a jailbroken phone, as I had no real reason to do the research on it. Well, I was never able to get the erase content and settings to work correctly; it would either freeze and require hard restart or it would go through the motions and never actually remove anything.

    After trying this a few times I became frustrated and decided to hook it up to iTunes and restore the way I always have.. using itunes and the modified host file for Saurik's redirect for gs.apple.com. Everything was going fine until I received an error code. First error I got was 1601, (http://support.apple.com/kb/TS3694#error1601). That was the only time that error popped up; since then it has been the 1013 error. Now, I have no clue whatsoever why it would have thrown that 1601 to begin with, as the 1601 error is what threw me into the recovery loop. I tried what it suggested, and attempted the restore once again; this time with error 1013 and recovery loops galore.

    After seeing that all was, in fact, not so peachy here, I decided to begin my research. I have downloaded the most recent tinyumbrella and attempted to force the phone out of recovery; I then attempted the "fix recovery" option. Neither worked, obviously. I have unchecked everything on the "advanced" tab, as numerous places have cited problems with leaving most of that checked. I noticed I was attempting to load 4.3.1 ipsw even though tinyumbrella told me my SHSH was not saved for that particular iOS. It DID happen to have 4.3.3 SHSH saved, so I downloaded a custom ipsw with bb 4.10.01. At this point, I have used both Saurik's redirect via hosts alone and I have used tinyumbrella's tss connection without the hosts mod to no avail! It all just put itself back into the recovery loop.

    Now, ever since I started getting the 1013 error, the phone shows up as random numbers in TU instead of "eric's iphone," the name of the device on the left sidebar of TU just shows an odd shaped question mark and a random amount of numbers. The numbers shown by the name correspond to the ECID (dec) number in the main body. Both the hex and dec ecids are different than the ones retrieved from Cydia. TU doesn't even show device name, installed firmware, installed baseband, serial number, OR my IMEI. Now, under recent devices, the old iPhone setup shows up perfectly! Not one missing box of info, not one invalid name.. nothing!

    Tried the same steps, but different IPSW, but got same results. At this point, I have used both Saurik's redirect via hosts alone and I have used tinyumbrella's tss connection to no avail! I decide to pursue a new path: redsn0w. I load the 4.3.3 ipsw and begin the jailbreak. It hangs up right at the end of the jailbreak, so I do a manual restart and jailbreak again. This time, the jailbreak is a success! The phone loads up and everything, I even fixed the recovery loop with that!

    Excited at my accomplishment, I swipe to enter. I cruise over to settings/general/about just to make sure it's all ok. This is when I notice that it shows no carrier (I kinda expected that one, being that the sim isn't 'mine' anymore) no wifi, no bluetooth, 00:00:00:00etc for MAC address, and shows a spot for the modem firmware, but the data-side is empty.

    Most everything I have read so far says it's about time to let this thing keep a stack of papers down. One site though, told me to use tinyumbrella to attempt a restore via itunes/TU tss server. They all say to expect the 1013 error. After the error, they say to put phone into DFU mode and attempt jailbreak with greenpois0n. For most of them, that solves the problem. The jailbreak fails each time I have tried.

    The only option that I have researched which I haven't tried yet is to do a full restore/upgrade in iTunes and hope for the best... If any way possible I would prefer to avoid this as the buyer had specifically requested that the phone not be upgraded.

    What I want to know before I try the iTunes update; is there any way I can find out exactly which baseband I am using without being able to see it through settings/general/about? I am assuming that I have somehow flubbed my baseband and am trying to install the incorrect ipsw for the current BB already installed.. Help!!

    If any more information is needed, I will happily provide! Thanks in advance!

    EDIT: from what I gather, if you get ANY code other than 1013, your BB has been updated. Is this true and does that explain my problem?
     
  2. lordcheeto thread starter macrumors newbie

    Joined:
    Jan 4, 2012

Share This Page