iPhone4 screen goes on/off every 15 seconds during stand-by

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Floris, Dec 8, 2010.

  1. Floris macrumors 68020

    Floris

    Joined:
    Sep 7, 2007
    Location:
    Netherlands
    #1
    When not on the USB charger and even with push off, and notifications off, or in air plane mode, etc .. the iPhone4 when in standby after pressing the top button at the top turns on the screen and shows the slider to unlock screen, about every 15 seconds.

    I found some discussions on apple.com but they are just closed for further commenting, and nobody posted a solution.

    Tips?

    I just got it November 22nd, first time iPhone user, so kinda bummed out about a silly thing like this. I've contacted dutch T-mobile via their webcare team on twitter, waiting their response. Right now I just want to exchange the phone if there's no simple option -- but hopefully this great community is familiar with this problem and tells me what a noob I am and points me to a button to click or app to uninstall or whatever ..

    iOS 4.2.1 on black 16gb iphone4
     
  2. Floris thread starter macrumors 68020

    Floris

    Joined:
    Sep 7, 2007
    Location:
    Netherlands
  3. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #3
    At least try restoring the phone, and preferably setup as new, and see if that fixes it.
     
  4. Floris thread starter macrumors 68020

    Floris

    Joined:
    Sep 7, 2007
    Location:
    Netherlands
    #4
    Yeah, the problem is I am new to it and just super enjoying the phone - everything works so smooth and we're working hard on our own apps. It's a bit silly having to do a restore when it's all going so well, except one thing.

    *closes eyes and presses restore button*
     
  5. Floris thread starter macrumors 68020

    Floris

    Joined:
    Sep 7, 2007
    Location:
    Netherlands
    #5
    I've restored a few times, including a clean restore with nothing on it.
    And no can do. It goes on / off every 10 to 15 seconds now. And battery is dead after 5 to 6 hours.

    I've contacted per twitter and per email to tmobile who I spoke before (during purchase) and haven't heard back.

    So I bumped those and will give them a tiny bit longer before calling customer services and documenting everything.

    I dunno what else I can do, or why this could be my fault. So, time for tmobile or apple to figure out who or what, but, factory issue: exchange it, ktnx. I guess.
     

Share This Page