Iphone4 wifi issues

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Nethus, Sep 23, 2010.

  1. Nethus macrumors newbie

    Nethus

    Joined:
    Sep 23, 2010
    Location:
    New Zealand
    #1
    Hi there,

    I've been doing a lot of searching but cannot seem to find a solution for my problem;

    My wifi connects perfectly but whenever the phone has autolocked itself for ~15min it stops pushing Internet notifications and on resume all apps that work over the Internet or network ie safari or apple remote don't function despite showing full wifi bars. To get the connection functioning again, it requires turning the wifi off and back on again.

    Hope someone can help as this is really proving to be a pain! Cheers
     
  2. mrmike316 macrumors regular

    Joined:
    Jun 21, 2009
    #2
    I am having the same exact problem, my son who has an iphone 4 sitting right next to me when it happens doesnt have a problem.Wondering if it is a problem with the phone,anyone else experiance this problem,,,THANKS
     
  3. Nethus thread starter macrumors newbie

    Nethus

    Joined:
    Sep 23, 2010
    Location:
    New Zealand
  4. Nethus thread starter macrumors newbie

    Nethus

    Joined:
    Sep 23, 2010
    Location:
    New Zealand
    #4
    I contacted Apple and they try to say that it's a feature that the iPhone4 disconnects from wifi a littlebit after sleep, but if you have autorejoin on it should rejoin the wifi network automatically.

    But this is not the problem at all, and the phone shows its still connected after resume, and doesn't rejoin the network automatically at all because it thinks it's still connected.

    Argh, where do I go from here?
     
  5. Nethus thread starter macrumors newbie

    Nethus

    Joined:
    Sep 23, 2010
    Location:
    New Zealand
    #5
    Sadly, we don't have an apple genius/retailer in New Zealand so I went into my phone provider, complained about what had happened, and they're going to send it away to apple.

    It's gotta be a hardware fault because restore doesn't work and there are phones running the same software with no problems. But Apple seem to disagree that there's no way it's their product. But all companies say that don't they!

    Would be interested in anyone elses follow ups to this problem with their phone, especially if you have an apple store where you are
     
  6. magicjosh macrumors newbie

    Joined:
    Jun 9, 2010
    #6
    Same problem. Hadn't really been a major headache until I bought my Apple TV and started using my phone as the remote. Now it sucks.
     
  7. leog macrumors newbie

    Joined:
    Mar 10, 2008
    #7
    Seeing the same thing!

    Makes the Remote app almost useless for me.

    I sent a bug report in to Apple, hopefully they get on this.
     
  8. whsbuss macrumors 68040

    whsbuss

    Joined:
    May 4, 2010
    Location:
    SE Penna.
    #8
    Same exact symptoms here. Didn't notice it on 4.0.2 because phone was so new but now on 4.1 it happens more often. Funny but push seems to work but when I come from sleep, wifi is on but cannot connect.

    I don't think this is hardware related and hope 4.2 in November fixes it. I would hate to have to exchange this unit as it has no other common problems (antenna, prox sensor).
     

Share This Page