iphones sharing recent contacts

Discussion in 'iPhone Tips, Help and Troubleshooting' started by jmdeegan, Apr 15, 2014.

  1. jmdeegan macrumors member

    Aug 17, 2007
    I am trying to figure this out, and I can't find the obvious reason.

    My wife and I have iphones. Her's is a 5c, mine a 5. i only use icloud on each for backups.

    I do not sync contacts for either phone, to the cloud. I have in the past, but not in some time.

    we have separate accounts to handle imessage.

    Basically...unless I missed a check box somewhere....they should not really be linked.

    So what is happening, is if I go to text someone, and say I start typing in "T", I see a whole bunch of contacts-many of which are on her phone, and whom I've never texted. they aren't in icloud. I cannot, for the life of me, figure out why i am seeing any of her recently texted numbers-and vice versa.

    when they come up, my options are of course to text them, or i can click on the i in the circle next to the name/number and "remove from recents". which I've now done for a number of them.

    my questions are twofold.

    1-What must I do to prevent this going forward? my phone is a work phone, and I have a huge number of contacts. My wife won't want to have all of them popping up in her recents.

    2-If I remove them from my phone's recent contacts....is the change shared with her phone, or is it something I have to repeat from her's as well

    thanks in advance
  2. C DM macrumors Westmere

    Oct 17, 2011
    So both phones have completely separate Apple IDs for everything, or somewhere something is shared?
  3. jmdeegan thread starter macrumors member

    Aug 17, 2007
    i do share itunes accounts, for music and apps. thats it.

    i didn't think that would cause the issue tho....but i guess i might be wrong?
  4. C DM macrumors Westmere

    Oct 17, 2011
    Something there might be doing it. So as far as iCloud goes, where there are settings like Documents & Data and Keychain and all that, is that separate/different for each one of the phones?
  5. Applejuiced macrumors Westmere


    Apr 16, 2008
    At the iPhone hacks section.
    Go to Settings/icloud/contacts
    If that is turned on then you are sharing all contacts between the phones.
    Turn that off.

Share This Page