iPhoto 08- Closing Unexpectedly, Slow, Other issues

Discussion in 'Mac Apps and Mac App Store' started by seanemac007, Aug 27, 2007.

  1. seanemac007 macrumors newbie

    Joined:
    Dec 4, 2006
    Location:
    California
    #1
    (System: G5 iMac, photos kept on external USB hard drive)

    iPhoto is the only application from the new iLife 08 that I have installed yet, and in theory, I love it. However, I am having constant issues with it.

    First, it will not stay open for more than 10 mins. If I walk away after only starting the program, doing nothing else, when I return it tells me it has unexpectedly quit.

    If I stay and work with it after it opens (and man does it take a while to open), I can't do much with it. One issue is if I click the slide show play button (lower left), the program freezes completely. Every single time. I have not started a single slide show to play in the program.

    I have not found anyone else mentioning that they are experiencing these issues (except some comments about its speed). Anyone else out there having these issues? I know it might be my external hard drive, but these issues are a little beyond what you would expect.
     
  2. artevie macrumors newbie

    Joined:
    Aug 29, 2007
    #2
    same problem!

    I have been using iphoto for a few days now and to begin with it worked fine. now whenever I open it and move my mouse to try and do something it just quits. Here's hoping someone out there has got the answer!
     
  3. lavrishevo macrumors 68000

    lavrishevo

    Joined:
    Jan 9, 2007
    Location:
    NJ
    #3
    Download ONYX and repair permissions
    Restart
    Reinstall iPhoto
    Repair permissions and optimize
    reboot and you should be good.
     
  4. tbealmear macrumors regular

    Joined:
    Jul 1, 2007
    Location:
    Morgantown, WV
    #4
    I am not having any of those problems, but I am having a problem with Front Row hanging when trying to access pictures that are in "events". It then comes up saying that iPhoto is not responding. I close front row and iphoto is open, but it is running just fine. Kinda strange. I gather from reading other things that there are quite a few problems with the new iPhoto.
     

Share This Page