iPhoto '08 Destroying Images. Help?

Discussion in 'Mac Apps and Mac App Store' started by mbabc, Sep 18, 2007.

  1. mbabc macrumors newbie

    Joined:
    Nov 3, 2006
    #1
    I'm using a 12" G4 Powerbook with OS 10.4.10.

    Using iPhoto 7.0.2 (341) I've now had two separate iPhoto libraries where photos were either corrupted or lost.

    In the first instance I noticed a problem trying to do a Retrospect Back-up and the procedure simply hung the program. Then when I tried to copy the whole library via the finder, the copy was interrupted with the message: "The Finder cannot complete the operation because some data in "IMG_0416.JPG" could not be read or written (Error code -36)"

    When I went into the library and tried to export the picture via the file menu, I was unable to do so. When I dragged the photo to the desktop, it seemed to go across but when I opened it in preview it was a partial photo and garbage.

    When I tried to duplicate the picture in iPhoto, I was unable to do so. I ascertained that there were close to 200 photos from several uploads that I couldn't duplicate. This was from uploads back in March of this year.

    In this instance, I did have a prior version of the library backed-up. I deleted the photos I couldn't duplicate and then imported versions from the prior back-up. It seemed to fix the problem, at this point.
    - -
    In the second instance, a different library, the photos simply disappeared from two separate imports. For import #1 (about 30 photos), the thumbnails were still there but when I double-clicked on the thumbnail, I got a greyed-out image with a exclamation point. In import #2 (about 70 photos), there were no thumbnails visible, just a faint outline where the photo should have been. Double-clicking on the thumb-outline got the same greyed-out image. These were recent imports, 2 and 1 weeks ago.

    In both instances, I had gone in and corrected many of the photos and deleted others -- the program seemed to be working just fine until the photos disappeared.

    The photos were completely gone. Import #1 was available as a back-up. Import #2 is lost and gone.
    - -
    - -
    Can any one tell me what's up here? I'm extremely nervous about using iPhoto at this point -- it seems that at any time my work could simply disappear. Can any one suggest what's wrong?
     
  2. itickings macrumors 6502a

    itickings

    Joined:
    Apr 14, 2007
    #2
    I'd be extremely nervous to use that computer for anything. If Retrospect Back-up hung and Finder failed to copy files, and pictures from iPhoto disappear or get corrupted, my primary suspect would be the hardware, not iPhoto.

    Have you tried verifying the disk from Disk Utility?
     
  3. mbabc thread starter macrumors newbie

    Joined:
    Nov 3, 2006
    #3
    Hard Disk Failure

    You were right. The hard disk was defective. I went to re-format it using my original system disk and it said there was a S.M.A.R.T. failure. It's a relatively new disk (3 months old -- a 160 GB replacement for the original) which is now replaced.
     
  4. iMacBook macrumors 6502a

    iMacBook

    Joined:
    Jun 14, 2007
    Location:
    Down by the bay.
    #4
    I don't think there is a need to format.

    I think you just need to repair permissions and such, but I'm not positive that that should be done. I remember I used Onyx and scanned my system and I had to repair something I believe and everything was fine after that.
     
  5. itickings macrumors 6502a

    itickings

    Joined:
    Apr 14, 2007
    #5
    Both correct and incorrect, iMacBook. It is true that re-formatting is overkill in most cases, since disk utilities can repair most soft errors. In this case however, the drive obviously was failing hard and physically.

    S.M.A.R.T. is in no way perfect, but if it throws out warnings or errors, one really should backup the data immediately and stop using the disk.

    If S.M.A.R.T. is reporting issues, AND one experiences data loss or corruption (as the OP), one can only hope that all important files have been backed up already. No amount of repairing permissions will do squat.
     

Share This Page