iPhoto 08 library problem

Discussion in 'Mac Apps and Mac App Store' started by superted666, Sep 4, 2007.

  1. superted666 Guest

    superted666

    Joined:
    Oct 17, 2005
    #1
    Hello,

    I fired up iphoto today to grab some pics from it and to my horror it loaded an says... No photo's.

    I delved into the package and thank god they are still there, whats my best way of getting iphoto back in shape?

    I Tried rebuilding the library but it took almost no time at all and came up with nothing.

    I tried moving some of the pref files out the folder to try and trick it into a rebuild but again nothing.

    The only thing i can think of is finding a way to export the photo's from the folders into a new folder then re-import into the library.

    What do you lot think ?

    If i do that though ill lose all my organizational info :(
     
  2. superted666 thread starter Guest

    superted666

    Joined:
    Oct 17, 2005
    #2
    Found the problem... Stand down!

    I had the library on a external disk and for some unknown reason the path has changed.

    Still need to work out why but if i hold option during launch of iphoto i can see and use the library
     
  3. Oilbrnr macrumors 6502

    Joined:
    Jun 15, 2007
    #3
    I'm a bit miffed myself. I loaded some pics yesterday (RAW) and went to upload one to a site, but could not browse to the files. I see the iPhoto Library icon on the external drive, but the sub folders are not there. If I look at the info for the actual photo in the application, it shows the path however. Is this some new option to 'hide' the actual files?
     
  4. skybolt macrumors 6502a

    Joined:
    Feb 20, 2005
    Location:
    Nashville, TN, USA
    #4
    Yes, it is a way to hide the files. Apple has done this to save us from mucking about in the finder and corrupting our photos! Best to do everything from within the app itself. Export photos to the desktop if you need to upload or otherwise work with them. Stay out of the finder -- corruption will ensue!
     

Share This Page