iPhoto '09 BUGGY?

Discussion in 'Mac Apps and Mac App Store' started by TomKease, Feb 18, 2009.

  1. TomKease macrumors member

    Joined:
    Oct 9, 2008
    #1
    HI

    I just installed iLife 09 and...the iPhoto is acting really slow.

    Everytime I go to edit a pic....when im done and I click the arrow to go to the next pic. It has the drop down progress bar that say "saving pic"

    Now this has happened before, now its on just about every other pic and its taking 2-5 mins.

    I'm not sure is its the software

    or if its cause my pics are from a 10 megapix camera now

    or is it sucking up my ram to render the pics?

    has anyone else had this problem?

    if so any solutions?

    TK
     
  2. stomer macrumors 6502a

    Joined:
    Apr 2, 2007
    Location:
    Leeds, UK
    #2
    For me iPhoto 09 is as slow as molasses. Using iPhoto has become a real chore. I'm desperately awaiting a patch.
     
  3. slieu92 macrumors regular

    Joined:
    Jun 28, 2008
    Location:
    California
    #3
    same, i was importing 3000 photos, 100% cpu on 2.4ghz imac, i switched to a different space, a mintue later, iphoto crashed, and when i finally got it back and imported, faces doesn't even work.:(
     
  4. stomer macrumors 6502a

    Joined:
    Apr 2, 2007
    Location:
    Leeds, UK
    #4
    Yep, I've had the same experience. It seems that the majority of my crashes have occurred when face recognition was running.
     
  5. KettyKrueger macrumors 6502

    KettyKrueger

    Joined:
    Feb 17, 2007
    Location:
    UK
    #5
    In my experience, I wouldn't say it's any slower than '08 but it is buggy, very buggy.

    I'm sure it won't be long beofre an up-date. The Garageband update was quick to appear.
     
  6. roger6106 macrumors regular

    Joined:
    Jun 19, 2007
    #6
    iPhoto '09 seems a little slower to me, although it's the bugs that are really annoying me. Many things that worked great in iPhoto '08 have bugs, most of the bugs that annoyed me in iPhoto '08 are still there, and the new features have introduced even more bugs (especially places). I thought they would have released a patch by now, but I guess it takes a while to patch so many bugs.
     
  7. GimmeSlack12 macrumors 603

    GimmeSlack12

    Joined:
    Apr 29, 2005
    Location:
    San Francisco
    #7
    I can only imagine what "bugs" you guys must be experiencing but I can only say that there is a slight lag when scrolling through pictures (over 9,000). The faces thing is fantastic, it takes 2 or 3 training pictures of a person but after that it really nails it. The places thing is great too. Hasn't crashed on me, not sure what's going on on everyone elses machines.
     
  8. tibi08 macrumors 6502a

    tibi08

    Joined:
    Sep 17, 2007
    Location:
    Brighton, UK
  9. roger6106 macrumors regular

    Joined:
    Jun 19, 2007
    #9
    I never mentioned crashing. I have not had iPhoto crash. Here are a few of the bugs I have run into:
    • Old bug: When searching for pictures by keywords, the list of keywords stretches off the screen if there are a lot of them.
    • Old bug: When adding keywords to pictures the drop down list of keywords appears and disappears.
    • Old bug: Press and hold the down arrow to scroll through a large list of pictures. The scrolling lags behind the selected picture. Sometimes I have to wait a few seconds for the scrolling to catch up before I can do anything.
    • New bug (I think): When scanning through an event or a face by hovering the pointer over the thumbnails, the thumbnails are out of order.
    • New bug: I cannot remove keyboard shortcuts from keywords. It worked once, but now no shortcuts can be removed.
    • New bug: I have have had the dock crash repeatedly while using iPhoto until I restarted iPhoto.
    • New bug: I have to restart iPhoto to get the editing toolbar to show up in fullscreen mode.
    • New feature bug: I have some pictures in my iPhoto library that have an incorrect place name (and no location coordinates). I do not know how this happened, but I cannot remove this place name.
    • Switching spaces when labeling a place in iPhoto '09 causes it to go crazy.
    • New feature bug: When viewing the location of a picture in the info pane (by clicking the "i" button, the maps of pictures is randomly zoomed in to different levels for different pictures, even if the pictures are taken within 5 feet of each other.
    • New feature bug: The thumbnails for some faces don't show.
    • New feature bug: Go to the naming view of a portrait oriented picture, and click right above or below the "add missing face" button. It exits out of naming view.

    I have submitted bug reports about most of these bugs (and many others) to Apple. Some of them are only mildly annoying, while some (like the spaces bug) are really frustrating. It amazes me that there are many people who aren't noticing any bugs.
     
  10. GimmeSlack12 macrumors 603

    GimmeSlack12

    Joined:
    Apr 29, 2005
    Location:
    San Francisco
    #10
    Fair enough, if the program doesn't work 100% right then ok, sure, report it. But let's relax a little on the whole "buggy" nay saying of iPhoto.

    It amazes you that people don't notice that the thumbnails are out of order when scanning? I amazes me that you do. And lag experienced with scrolling isn't a bug.

    As for the Spaces bug, I would recommend you finish labeling something before switching Spaces. I have problems with MS Office and Spaces and therefore I completely understand the maddening frustration with such malfunctions.
     
  11. vincebio macrumors 6502a

    vincebio

    Joined:
    Jun 27, 2005
    Location:
    Glasgow
    #11
    .

    why???? just because you dont have the bugs means were not supposed to talk about them....:rolleyes:

    my iphoto 08 catalogue of 8000 pictures didnt lag when scrolling.....so i can assure you its a bug. sorry, i know how much you wont accept bugs and all......but

    why should anyone have to do workarounds when a previous version didnt require so?

    if your happy with your less than 100% product thats up to you...were not.
     
  12. roger6106 macrumors regular

    Joined:
    Jun 19, 2007
    #12
    I don't expect anybody to run into every bug that I've listed. What surprises me are when there are people who don't notice any bugs.

    The thumbnails being out of order while scanning gets rid of the whole point of being able to scan through them.

    The lag during scrolling definitely is a bug. If I scroll using the scroll bar it goes there instantly. If I use the arrow keys it lags behind. Sometimes I have to wait for a few seconds before it finally catches up.

    I'm sure Apple will release a patch soon that corrects many of these bugs, but until then they are a problem.
     
  13. mrkgoo macrumors 65816

    Joined:
    Aug 18, 2005
    #13
    I've noticed a few of those bugs.

    Anyway, I think I know what is causing one of your bugs - the one about locations being assigned, but no coordinates, and you can't remove it?

    If you assigned a location to an event (an event location), it will put all the photos in that event as part of that location, but this is NOT the same as individually labelling the photo inside with that location.

    I suspect the event that that photo was labelled with a location, assigning it globally with that image. If you want to remove that location, you have to remove the event location first.
     
  14. bunmun macrumors newbie

    Joined:
    Jun 18, 2009
    #14
    It's very buggy for me too. I'm trying to add locations to events and sometimes iPhoto will stop responding for a while. It can also freeze my whole desktop for a minute.
     
  15. mrkgoo macrumors 65816

    Joined:
    Aug 18, 2005
    #15
    I think a lot of the speed relate issues may be a network thing. For example, loading iPhoto has become slower, but is faster at my workplace where I have a faster connection.
     
  16. iAlexG macrumors 6502

    iAlexG

    Joined:
    Jun 15, 2009
    Location:
    Florida, Missing Britain.
    #16
    For me initially opening iPhoto is slow and Enhancing a photo is slow but the other features are fine
     
  17. nufanec macrumors regular

    Joined:
    Sep 10, 2005
    #17
    Admittedly I don't use iPhoto a lot, maybe one a week or so, but I haven't noticed any problems. Just as fast as '08 for me. Everything is snappy.
     
  18. AsterixGM macrumors newbie

    Joined:
    Jun 30, 2009
    #18
    Anyone else having the issue where you tag using Faces name and it won't capitalize the first letter of the name? "J" won't capitalize for me specifically.
     
  19. mrkgoo macrumors 65816

    Joined:
    Aug 18, 2005
    #19
    I had a similar issue. It kept trying to autocomplete a similar name I didn't want. I kept trying and eventually I got there (like copying and pasting capitalised versions).
     
  20. Mycatisbigfoot macrumors regular

    Joined:
    Jun 22, 2009
    #20
    I was looking on some posts about Iphoto,

    Mine is very buggy, I rater 08, But I lost my 08 Disk, and my mac book reinstall disks, I have had to reinstall iphoto 09 about 3 times, I try not to use it, But its very slow, I have not had the spaces bug, also my pictures stop syncing to my ipod, after i got 3.0 on it

    I'm backing up my iphoto to another mac and then im going to reinstall 09, and see if that fixes, it, I do not even have an iphoto file in my user folder under pictures
     

Share This Page