iPhoto '09 can't delete empty thumbnails/rebuild

Discussion in 'Mac Apps and Mac App Store' started by macstatic, Feb 19, 2015.

  1. macstatic macrumors 6502a

    Joined:
    Oct 21, 2005
    #1
    After having done a "Force quit" for iPhoto (it wouldn't quit after I had worked on some albums, deleting photos etc.) I now have a bunch of empty thumbnails for the photos I deleted/emptied iPhoto's trash.

    I've tried all the rebuild options available (holding down ALT and CMD while starting iPhoto gives various rebuild options) but this hasn't solved my problem. I'm still unable to delete all those empty thumbnails representing the photos I deleted. If I select those empty thumbnails (they all have a generic "dotted-line frame"), delete them (ALT, CMD and BACKSPACE) and finally empty iPhoto's trash (right-click on the trashcan icon) and try to quit then iPhoto just hangs indefinitely. So once again I have to perform a "Force quit".

    How do I fix my iPhoto library? I'm using iPhoto '09 (version 8.1.2) on OSX 10.6.8.
     
  2. macstatic thread starter macrumors 6502a

    Joined:
    Oct 21, 2005
    #2
    I worked it out!
    I don't know if it was a combination of things, but what I did was go to the "Photos" section (top left hand area, where it says "Library", drag all the "missing photo" thumbnails over to the trashcan. Finally I emptied the trash and quit iPhoto. This time it didn't freeze as before!
    Seems like just dragging the missing thumbnails over to the trashcan instead of deleting them (ALT, CMD, BACKSPACE) was the solution.

    Oh, if there's a lot of work involved I try not to do everything in one go but do part of the job, then quit iPhoto before starting it again and continuing. That way iPhoto gets the opportunity to write any new information to its database/setup in between.
     

Share This Page