iPhoto '09 Default Map Location

Discussion in 'Mac Apps and Mac App Store' started by Maffoo, Jan 31, 2009.

  1. Maffoo macrumors newbie

    Joined:
    Jul 20, 2006
    Location:
    Leeds, UK
    #1
    I've just upgraded to iLife '09 and when I try and add a New Place the default map location is Cardiff... It's really annoying me as the vast majority of my photos are taken around London, I've never even been to Cardiff so this is highly annoying!

    Is there any way to change it?
     
  2. TPMann GB macrumors member

    Joined:
    Mar 29, 2008
    Location:
    South West England
    #2
    I've noticed this as well and it's rather annoying! I have no photos tagged near South Wales, but it defaults there every time. I also live nowhere near there, so I'm guessing it can be going by IP address.

    iPhoto 09 also takes longer to load on my MBP, and no longer seems to say "Loading" when it starts up.
     
  3. g-7 macrumors 6502

    g-7

    Joined:
    Feb 14, 2006
    Location:
    Poland
    #3
    Same thing happens here, all the Polish regions are labelled incorrectly. When I import a photo taken with iPhone (with GPS data embedded), iPhoto shows the correct position on the map, but uses completely wrong and sometimes ridiculous label. When I try to change the label, it removes the pinned location from the photo.

    Annoying and basically useless. :mad:
     
  4. Carnivor macrumors regular

    Carnivor

    Joined:
    Feb 24, 2008
    #4
    Its default location is taken from your Regional Settings, as you know, there arn't many UK based ones there.

    im 50/50 between Cardiff and London, so loose/loose for me
     
  5. Applespider macrumors G4

    Applespider

    Joined:
    Jan 20, 2004
    Location:
    looking through rose-tinted spectacles...
    #5
    Carnivor is right.

    Go to System Preferences, Date & Time and check that your Time Zone is set to London. Then Google Search in iPhoto will start off in London.
     
  6. Carnivor macrumors regular

    Carnivor

    Joined:
    Feb 24, 2008
    #6

    Not only am i right (gloat) ive sorted it out

    Use Google Earth to get the coords you want to use.

    Show Package Contents of DateAndTime.prefPane

    Show Package Contents of TimeZone.prefPane


    open all_cities_adj.plist


    I edited the London setting to reflect Bristol, I only changed the Bold settings,

    <array>
    <string>51.500000</string>
    <string>-0.166656</string>
    <string>11</string>
    <string>Europe/London</string>
    <string>GB</string>
    <string>London</string>
    <string>England</string>
    </array>

    Save All and goto date/time timezone, Now you can pick Bristol - England

    Im everso slightly out on the coords but iphoto now shows Bristol as its default location instead of London or Cardiff,

    ohh btw, London is the only city in England so you can search for England to find that array.

    edit: forgot to mention, I editied London on this occasion but it would be easy enough to add places instead of renaming them
     
  7. Carnivor macrumors regular

    Carnivor

    Joined:
    Feb 24, 2008
    #7
    Dunno if you should try this yet, i just rebooted, and now i cant launch finder
     
  8. Carnivor macrumors regular

    Carnivor

    Joined:
    Feb 24, 2008
    #8
    Ran a disk repair and all working again,

    Although i do notice that when i set to Bristol its a bit iffy if it stays, it keeps reverting to Cardiff, which i didn't have set in the first place.

    the search continues...
     
  9. Carnivor macrumors regular

    Carnivor

    Joined:
    Feb 24, 2008
    #10
    found my problem, I had Europe/Bristol instead of Europe/London for the 4th string down,

    <array>
    <string>51.470000</string>
    <string>-2.556656</string>
    <string>11</string>
    <string>Europe/London</string>
    <string>GB</string>
    <string>Bristol</string>
    <string>England</string>
    </array>

    incidently, those coords give a good Bristol Area in iphoto!!

    All working sweetly now
     
  10. Skyfarmer macrumors newbie

    Joined:
    Jan 8, 2009
    #11
    Well, I can't get it to work at all.

    I have tried to add Jersey, instead of Bristol, but I just do not get it (Jersey) appearing in the Time Zones tab.
    Running with Max OSx Ver 10.5.7
    Has something perhaps changed in this version of the OS that means another step is required?.

    I did wonder about this bit:
    Control-click on "all_cities_adj.plist" and choose "Get Info", then click on "Ownership and Privileges".
    click on the lock icon
    change owner from "system" to " (me)" (whoever you are logged in as).
    at the prompt, enter the root password.
    close the info window


    In 10.5.7 there is no ownership...section of the Info pane, only Sharing and Permissions. I changed my privileg to Read & Write, edited the relevan files and then changed it back to Read only. I would have assumed that this is exactly the same thing, but maybe I am wrong and this is causing some sort of problem?

    Any ideas?


    I have just tried to change the co ordinates on the Cardiff section of the all_cities_adj.plist file and it still does not change the position of the map under iPhoto places.

    Neil

    Edit

    Done it now and all works. It was a file ownership problem. You need to go to terminal and use sudo chown to change file ownership back to root (system). This doe not seem possible from within the GUI, so Terminal is the only way
    I outlined how I did it here:
    http://discussions.apple.com/thread.jspa?messageID=9984168&#9984168
     

Share This Page