iPhoto 09 does not read keywords from files (IPTC Metadata) ?!?

Discussion in 'Mac Apps and Mac App Store' started by pedroL, Jan 28, 2009.

  1. pedroL macrumors newbie

    Joined:
    Dec 12, 2008
    Location:
    Porto, Portugal
    #1
    Hi Mac users!

    I installed iPhoto 09 today and I'm having a hard time figuring out why does this new version does not read keywords from my image files (IPTC Metadata) !

    All my photos are tagged with keywords "inside" the files (IPTC Metadata) and with iPhoto 08 all I had to do was to import the files to iPhoto and it would recognise those keywords!

    Now, in iPhoto 09, those "inner" keywords (IPTC Metadata) aren't recognised!
    Did Apple remove the IPTC Metadata support in iPhoto 09?
    Solutions?

    Thanks for your help!

    ---EDIT---

    From what I have read at Apple Discussions, there is a bug on iPhoto 09 that stops the support of IPTC Metadata ONLY when the option "Copy items to the iPhoto library" isn't ticked!
    If the photos are imported and copied to the iPhoto Library then there is no problem and the keywords are recognised!
    Strange...
     
  2. PeaceOut macrumors member

    Joined:
    May 17, 2008
    #2
    I'm having problems with this too.
    I use iPhoto as an viewer/organizer and so I'd rather not have iPhoto move and handle my images which is why I don't do the copy setting. But I would like to have my keywords and camera information present and viewable.

    This may be a quirk but I found that when I rotate a photo (with metadata) in Adobe Bridge and then import it into iPhoto 09, they show up. But not the others.

    Strange :confused:
     
  3. pedroL thread starter macrumors newbie

    Joined:
    Dec 12, 2008
    Location:
    Porto, Portugal
    #3
    I haven't found a solution for this enormous issue! :(

    But what you've found is one of the strangest things I've seen in Mac!:eek:
    Very very strange...

    I hope there will be a fix someday...
     
  4. PeaceOut macrumors member

    Joined:
    May 17, 2008
    #4



    I figured out the rotating thing.
    When you do a rotate with Adobe Bridge or Adobe lightroom, all they do is change the metadata field "orientation" to rotated 90. None of the pixels have been changed, just the metadata. Most programs read this metadata information and show a rotated photo...but in reality, the photo hasn't changed.

    So here comes iPhoto. If you have your iPhoto set to just link your images and you import a photo with a metadata tag that has the field "orientation" set to anything other than normal, it thinks of it as a file that needs to be modified. So it edits the file and puts it in a modified folder. So what you see is a modified file...not the linked one. So in essence, that file has been imported into iPhoto as a copy...which is why the keywords show.

    This is the same when you rotate the photo in iPhoto or do any editing.
     
  5. pedroL thread starter macrumors newbie

    Joined:
    Dec 12, 2008
    Location:
    Porto, Portugal
    #5
    Thanks for making me understand this bug a little better, PeaceOut !

    So, if I understood it correctly, we do know why it happens but we still can't circumvent our problem...
    I would expect that Apple would have this one already fixed by now... :(
     
  6. PeaceOut macrumors member

    Joined:
    May 17, 2008
    #6
    I'm sure they'll come out with a fix soon.
    I'm surprised that they haven't yet as I saw an update for garageband '09 just the other day.

    I noticed also that all my photos that were imported with iphoto '08 carried over the metadata info so I'm sure it's a simple bug.

    I belive once they fix it, we'll just have to make iphoto rebuild it's library which should be fairly simple process, option+command+run iPhoto (i think), (but could take a long time depending on the size of your library).
     
  7. pedroL thread starter macrumors newbie

    Joined:
    Dec 12, 2008
    Location:
    Porto, Portugal
    #7
    Like you, I really hope Apple fixes this one...
    iPhoto will be in standby mode for me till then... :)
     
  8. pedroL thread starter macrumors newbie

    Joined:
    Dec 12, 2008
    Location:
    Porto, Portugal
    #8
    ISSUE SOLVED WITH 8.0.1 UPDATE !!!

    PeaceOut:
    I think our iPhoto problems are over... do you also confirm this?
    I'm importing my photos right now and the first ones are keyworded! :)
     
  9. PeaceOut macrumors member

    Joined:
    May 17, 2008
    #9



    Yeah. With the update, the keywords are showing up for new photos imported.

    But all the photos that I have already had don't show. I even did a rebuild and it didn't work.
    I guess I can re-import them all but that would get rid of all the faces that I have tagged....*sigh*
     
  10. pedroL thread starter macrumors newbie

    Joined:
    Dec 12, 2008
    Location:
    Porto, Portugal
    #10
    That's NOT a pretty picture... :(
    Doing it all over again is extremely boring and time wasting!

    I'm glad I didn't like the "faces feature" and didn't applied it!
    I tested it with a couple of photos and it failed big time! For example, iPhoto's faces feature confused my brother with a solid rock monument! :eek:
    Doesn't seem to work very well! Eheh!

    For me, there's no need to use faces because the keywords features are now working on import and their all tagged with peoples names, events and locations! :)

    Good luck with the re-importing PeaceOut!
     

Share This Page