iPhoto 09 - Modified Pictures show Exclamation Mark

Discussion in 'Mac Apps and Mac App Store' started by NightFox, Sep 13, 2009.

  1. NightFox macrumors 68000

    NightFox

    Joined:
    May 10, 2005
    Location:
    Shropshire, UK
    #1
    Earlier today I copied my iPhoto library file and the iPhoto prefs file to from my Mac Pro to my MacBook (using Chronosync's "mirror" option), for a week away from home.

    I've now come to using iPhoto on my MacBook, and noticed that the thumbnails for my modified pictures had reverted to thumbnails of the originals. Clicking on any of these modified images just brings up a large exclamation mark on a grey circle background.

    I know that this normally means that iPhoto cannot find the relevant file in the library (usually because someone's been messing around in the library - which I haven't; I took a mirror image), but the odd thing is if I click on "Edit", the image I'm then presented with is the modified image, so it's still there and iPhoto damn well knows it.

    I've tried opening iPhoto with alt-opt to get it to rebuild everything, but it hasn't made any difference.

    Any suggestions please?
     
  2. whyrichard macrumors 68000

    Joined:
    Aug 15, 2002
    #2
    I had a similar problem... though it seemed to be just from copying the iphoto library from one computer to another... not absolutely certain what triggered it...


    ... and i didn't come to realize that clicking on the edit brought up a full res... i just managed to reimport my pictures (was lucky to have them around) and lost A LOT OF TRUST IN IPHOTO.


    anyone know why this happens?

    thanks,
    r.
     
  3. AAPLaday Guest

    AAPLaday

    Joined:
    Aug 6, 2008
    Location:
    Manchester UK
    #3
    I had a similar problem Here which i have detailed here, i haven't found a cure yet so i have kept a separate copy of my photos on an external hard drive as its still not been fixed for me
     

Share This Page