iPhoto '11 bug?

Discussion in 'Digital Photography' started by Nytro, Oct 23, 2010.

  1. Nytro macrumors newbie

    Oct 23, 2010
    I just got my new copy of iLife '11. I'm on a late 2009 MacBook Pro 13". With iPhoto '09 I never had a problem. But now, I've searched high and low and no one seems to have my problem.

    I know that now you can't add new places from the My Places tab, it's from that sidebar at the right, in the map below. It's written in a supposedly text tab "Search places", where you can search new places and that. But, seeing that no one has this problem, it looks like it's some kind of rare bug that IS KILLING ME!:

    I can't click that tab. Really, I tried for like half-a-hour clicking as hard as I can, I searched for forum posts, etc., but nothing! Like, the tab where I supposedly write the place's name I'm looking for doesn't work! I put my mouse cursor over, and it highlights, alright! But when I click nothing happens. I tried to type on the keyboard, and everything, but nothing...

    And now I'm afraid that I can't go back to iLife '09, because I has one of those "new Macs" that came with everything on it. But now, '09 is gone and I only have '11 installed. And no, I don't use Time Machine. Please, help me! This is killing me! Thank you very much!
  2. jfeiner macrumors newbie

    Dec 14, 2008
    Southern Calif
    First click on the pin

    It's really difficult to assign a place now I noticed since you can't get it to work on the big map and have to do it only on the small one. If you click the pin and turn it yellow so you can move it it also gives you a text box where you can enter the location and search it that way. This must be a bug since places is virtually useless if only manipulated in the little box in the bottom right hand corner. Hopefully there'll be a fix.

    Attached Files:

  3. Nytro thread starter macrumors newbie

    Oct 23, 2010
    I found the fix! I posted on various forums and question sites, and I got an answer! From what I understand, it was not an app's bug: it was a system glitch. I just needed to delete the .plist file in Users/Library/Preferences. (com.apple.iPhoto.plist). It deleted my settings but I prefer setting up my hundreds of photos again than having a glitchy iPhoto!

    Thank you anyway!
  4. zzen macrumors newbie

    Sep 27, 2004
    Pin doesn't turn yellow!

    Thank you for posting this jfeiner! Now I know that there must be a bug with my iPhoto! My pin will never turn yellow, regardless how much I click on it. (yes, in the infopanel, NOT in Places)

    Wondering what to do now. This is a fairly big bug for me and I have no idea how to resolve it.

Share This Page