iPhoto '11 email sharing takes forever

Discussion in 'Mac Apps and Mac App Store' started by 1BadMac, Oct 23, 2010.

  1. 1BadMac macrumors 6502

    1BadMac

    Joined:
    Jan 27, 2010
    #1
    I've done a couple of single image emails that were under 2mb in size. Decent cable upload/download speeds usually, but this is pretty slow. 2-4 minutes per email before it says "Sent".

    Anyone else experiencing this? Pretty annoying and makes it just about a worthless feature. By comparison, I'm able to attach and upload in Gmail in about 15 seconds.
     
  2. jackmcdaid macrumors newbie

    Joined:
    Oct 25, 2010
    #2
    mine wont even send EVER

    I am also having problems with emailing photos in iPhoto 11. After I hit send the progress bar goes to full then nothing happens. Finally I get a message that "The email server didn't recognize your username/password combination." So I reentered my data and still not having any luck... dang, i really like the new templates too.... i was SO wanting to use this!!!!
     
  3. jackmcdaid macrumors newbie

    Joined:
    Oct 25, 2010
    #3
    Update

    I had success in sending my email message with the photo from iPhoto. The trick was to update my password in the correct account in the iPhoto preferences. I had changed my password a few weeks ago and for some reason iPhoto did not have the most current password... So now my photos go out very quickly!
     
  4. nospeed411 macrumors 6502a

    Joined:
    Jan 15, 2010
    Location:
    east coast
    #4
    Does not work for me...new iPhoto sucks. The features are all well and good in theory but for gods sake I could build my own template and attach it to a regular email message quicker than this does. Takes 3 to 4 mins to send one damn pic and then it's a 50/50 shot as to whether it will come up with an error message about missing password crap.
     
  5. thogs_cave macrumors regular

    thogs_cave

    Joined:
    Sep 25, 2003
    Location:
    State of Confusion
    #5
    I finally got it to send mail by dragging my desired account to the top of the accounts list in the preferences, even though I was selecting that account from the pull-down menu. (I have several.)

    What a pain. So far, so not impressed.
     
  6. Hipmister macrumors newbie

    Joined:
    Nov 6, 2011
    #6
    Change iphoto default email preference

    Go to iphoto Preferences.

    Under General, change the "Email photos using:" to your email program and it will work as previous versions of iPhoto
     

Share This Page