iPhoto '11 library update problems?

Discussion in 'Mac Apps and Mac App Store' started by jdsam, Oct 20, 2010.

  1. jdsam macrumors member


    Feb 10, 2007
    Hanover, NH ... for now
    Has anyone else had issues with the iPhoto '11 library upgrade? My upgrade seems to crash iPhoto and I have not been able to get iPhoto working.

    When I started iPhoto for the first time after the iLife update it had the usual "this library must be updated to work with this version of iPhoto" (that might not be the exact wording). Thoughtlessly I approved the dialogue as usual. The upgrade process made it through the first quick progress bar, but nearly immediately after starting the second progress bar iPhoto crashed. After restarting my mbp and opening iPhoto I got the same result. I even went so far as to reinstall the new iPhoto.

    Based on previous issues I tried holding option-command while starting iPhoto to get the rebuild dialogue and again the rebuild crashed iPhoto.

    Has anyone else been having the same issues or have any insight on how to resolve the issue?

    For the record I'm running a "late 2009" 15" mbp with 4GB ram
  2. ticzon macrumors newbie

    Oct 20, 2010
    Same Problem

    I too have the same problem...almost. While doing the upgrade of my library, iPhoto crashed and said it couldn't find a plug in. Then when I launch it again, I got the gray screen with the spinning wheel and a spinning beach ball. I let it run for about 30 min and figure that something is wrong. Did a force quit after reading the window before doing the force quit, "iphoto was not responding"

    Repaired permissions and reinstalled iLife 11. Then restart my Mac. Relaunch iPhoto and it said it had to upgrade my library. After upgrading, I have no photos. The albums are listed and the events are listed. However, the thumbnail on the event folders don't show any photos. When I select a event, again no photos. All of my 25K+ photos are now gone!

    I did a right click on my iPhoto library (to see package contents) and can't find the original photo folder ( iLife09 iPhoto had an original folder, where the original photos were stored) iLife 11 iPhoto library doesn't have an original photo file (Not Good). I used to copy contents of this folder when I did my backup to an outside location from my house.

    I am now restoring my library from my time machine (I'm thankful that I have time machine). My library is about 70gb. It will take time machine 4 hours to restore the library. I'm pretty upset. Can I get my money back? Yea, I wish.

    UPDATE: Noticed that my iPhoto library has gone from 72 GB to 9 GB. I now know that I lost my photos with this upgrade. (Still restoring with Time Machine).
  3. Endrance macrumors newbie

    Jan 26, 2010
    got the same problem.
    after every time i start iphoto 11, it asks me to refresh my database or close.
  4. Drewswa77 macrumors member

    Jun 18, 2004
    Boise, ID
    Same Issue

    My upgrade to iPhoto11 also went bad. After installing and choosing to upgrade the library iPhoto just claimed that it was unable to open the Library. I had to uninstall iPhoto11 with AppZapper , reinstall 09 and then recover the library with timemachine. Everything is ok now back in iPhoto 09.

    -By the way I first tried restoring from timemachine and opening again in iPhoto 11 and it still didnt work. Had to go back to iPhoto 09.
  5. jdsam thread starter macrumors member


    Feb 10, 2007
    Hanover, NH ... for now
    My solution

    As I said, I was having the same problem. After installing iLife '11 I opened the new iPhoto '11 and i got the standard "this library needs to be upgraded" message. I, naturally, clicked upgrade. After the second progress bar appeared and started to progress it stalled. The spinning wheel in the iPhoto window did the same, then iPhoto promptly crashed.

    The solution that I came up with was starting my computer in target disk mode to connect to another mac with iLife '09. First, I rebuilt the iphoto library and had it repair permissions to see if those were the problems. You can do that by holding command-option while opening iPhoto and you get a few options for rebuilding/checking different parts of the iPhoto library.

    That didn't seem to make a difference when I tried upgrading the library again in iPhoto '11, but it could have made a difference further down the line.

    So, I started in target disk mode again and opened my library with the iPhoto '09 again, but this time I went through and deleted all of the videos I had in my iPhoto library. I manually copied and pasted them into a separate folder on my computer before emptying the trash.

    When I restarted and opened iPhoto '11 after getting rid of my movies the library upgrade went just fine. Now, I don't know if the problem was the fact that I had movies or the fact that the movies were AVIs. I think it was the fact that they were AVI files because I saw something about AVI come up in the crash reporter when the library updates caused iphoto to crash.

    This may not be the exact problem that all of you have been experiencing, but I hope this helps someone.

  6. hikeNM macrumors 6502a

    Sep 29, 2004
    Somewhere close to a dairy in East Texas
    Sounding promising. Anybody with a good or, I should say, trouble-free installation?
  7. Halon X macrumors regular

    Sep 22, 2005
    Malibu, CA
    Smooth install, no problems here.

    Loving iLife 11.
  8. netnothing macrumors 68040


    Mar 13, 2007
    No problem here upgrading a 102GB library on my 2006 Mac Pro.

    Have to say so far with iPhoto and iMovie '11.....I'm not impressed with the performance. Performance seems worse than '09.

    I realize I have an older machine....but geesh...I have 11GB of RAM and like I said '09 ran better. Here's waiting for .1!

  9. DenisK macrumors member

    Nov 6, 2008
    No full screen, no dual screen, not 64 bit! I want my money back!!!

    Installed on mine without problems on a 3 y.o. 15MBP and a new iMac. See no performance issues so far, but I HATE the fact that the FULL SCREEN photo viewing is no longer there! I just hate it, that there is absolutely no way to view pictures full screen. period. (this was THE MOST important feature of iPhoto.) As such, zooming in full screen is NOT available anymore either, instead of floating windows with adjustments, etc., zoom, effects, you get stupid permanent bars that you can't even move anywhere. Also, gone is ability to quick launch a full screen slideshow. You are now asked to select photos for a slideshow first, and then create that slideshow. In Classic you will get an ability to view these full screen, thats the only way. The stupid music that accompanies classic is ... well, stupid. I just wish the Apple store in Bethesda MD had it installed so I could see how horrible it is, before giving them $79 for a Family Pack! My money now goes to Adobe for LR3, a much, much better suite! Forgot to mention, this version is NOT 64 bit, and it does not recognize dual-screen mode either, something that Adobe implemented years ago. Shame on APple for dummifying a simple photo viewer to the iPhone/iPad level. In fact, I hate it so much I will start a new thread!
  10. LimeyYankee macrumors newbie

    Jul 2, 2007
    Sorry to hear about you'll's problems! Thankfully, mine went smoothly on a month old 15" MacBook Pro and 5 GB library.

    I hope you'll get your pictures back!

  11. nicolle19 macrumors member

    Jan 4, 2007
    I am currently having the same issues. Talked to applecare tried they suggested to restore from Time Machine. I tried twice gets about 2gigs then says that I do not have permissions. Applecare had me download a program to get data from my computer and send to their engineers. The rep said she is off this weekend and most likely wont be till Monday till. I here something. I have 38 gigs of photos/videos unable to view because of the ilife 11 update
  12. netnothing macrumors 68040


    Mar 13, 2007
    Please, if you have hard drive space, do a manual copy of your iPhoto library. This will save you TONS of time if the upgrade fails. Just go to your Pictures folder and duplicate the iPhoto Library item. If the upgrade fails, you can delete the current one and rename the old one. No messing with restores from Time Machine.

  13. nicolle19 macrumors member

    Jan 4, 2007
    I would but it is like my pictures are not there. It says the file size is 838 That is why having to do it from time machine. I wonder why it says I do not have permission. I even tried to manually move the backed up iphoto library from time machine.
  14. err404 macrumors 68020

    Mar 4, 2007
    Upgrading my iTunes '09 library to '11 was crashing with an error in aviimporter. to fix the issue, I opened my iPhoto Library with "show contents" and searched for all "avi" files. I moved the files to a folder on my desktop. On the next launch of iPhoto, the library upgrade was successful.
    Now I just need to re-import the movies into iPhoto.
  15. Weaselboy Moderator


    Staff Member

    Jan 23, 2005
    Were you able to import the AVI vids back into iPhoto 11?
  16. err404 macrumors 68020

    Mar 4, 2007
    Not all of them. The ones causing the issue were from a 4 year old Fuji Point and Shoot (F10). These AVI files will not play in Quicktime at all, but do work in VLC. I'm sure that I can transcode them latter into a format that Quicktime (and therefore iPhoto) can read and then import them again. I think that these have been in my library since before Snow Leopard and Quicktime X.
    So for those having issues, some of the problems may be coming from files in your library that iPhoto can not read (it may not be AVIs in every case). The crash report may help you narrow down the offending file(s).
    The good news is that if you are having issues, your library itself should be ok, but you may be stuck until Apple updates iPhoto to better handle these conditions.
  17. samzhao macrumors newbie

    Oct 25, 2010
    Exactly the same problem, and I have the same MBP,too
  18. zurichawes macrumors newbie

    Oct 25, 2010

    i was stuck like all of you, but i found this article:


    i followed these steps:

    Go to the library file on disk, right-click it and select "Show Package Contents." Then locate and remove the following items:



    i repaired permissions in disk utility.


    go to the /username/Library/Preferences/ folder and remove the file "com.apple.iPhoto.plist."

    Then relaunch iPhoto.

    It worked for me. :D
  19. 42baum macrumors newbie

    Jun 9, 2007
    Fix for iLife Installations

    After reading many forum threads, I used the following techniques and achieved a flawless installation of iLife 11. Do the following things, in the order listed.

    1. Go to Font Book in Applications. Select Edit/Show All Duplicate Fonts. Then select Edit/Resolve All Duplicates.

    2. Open your current version of iPhoto. Delete all videos and delete all Projects and Keepsakes. These are not compatible with iPhoto 11. Empty your iPhoto trash.

    3. Install iLfie 11, but do not open any of the applications yet.

    4. After the installation, immediately run Repair Disk Permissions.

    5. Now you should be able to open iPhoto and it will only upgrade your library one time. You should be good to go. However, beware that it may quit unexpectedly like mine did. And there is a glitch. If you select a photo and then hit the Edit button to open another application for editing, iPhoto will create a duplicate of the original photo right next to the one you edited in that Event. Just move the second one to the iPhoto trash. Apple needs to fix that!

    6. You will also discover that iPhoto no longer lists your Event titles with the folders where your photos are stored in the iPhoto library. To work around this, go into Finder under iPhoto library and do a right click. Select "Show Package Contents." Your new photos will be listed inside the "Masters" folder. You have to drill down through "10" for October, and then to the day that the Event was created. Once you find the final folder where your Event is stored, make an alias of it and move the alias to a convenient folder where you would like to organize your photos. Aliased photos will show up in other applications. Just remember to always save new versions of them in a separate location.
  20. macabouttobe macrumors regular


    Aug 5, 2007
    No problems whatsoever..

    Out of an abundance of caution (and reading a few sordid stories) I did the following (in addition to Time Machine backup) prior to installing '11

    - copied 56gig iPhoto Library to an external drive
    - Rebuilt '09 database by holding down option/ctrl and launching iPhoto
    - fixed all permissions on hard drive

    Inserted '11 DVD, walked away for probably an hour (doubt it took that long but don't know). Whala! Easy Cheesy.
  21. err404 macrumors 68020

    Mar 4, 2007
    The upgrade is painless for the vast majority of users. Most of the pre-upgrade repairs/rebuilds are probably a waste of time. Repairing permissions certainly wont hurt anything, but don't let it give you a false sense of security. Every post that I have seen with a real explanation of the problem comes back to some incompatible file that iPhoto 11 can't understand and results in a crash during the upgrade. Permission repairs will not fix these issues. Some video files, Projects and Keepsakes seem to be the main cause of problems.

    Unfortunately tracking down the offending files is a difficult task. I would recommend that most users wait for an update to iPhoto 11 and/or you make sure that your library is backed up prior to the upgrade so you can roll back to iPhoto 09.
    Also wait until you have a few days buffer before you upgrade. Don't upgrade on Friday, if you plan to show your photos on Saturday.
  22. Tankfantry macrumors regular


    Apr 21, 2010
    Houston, Texas
    So I am sitting on iLife '11 but from what I am hearing I shouldn't install it. Is everyone having issues?
  23. ticzon macrumors newbie

    Oct 20, 2010
    iPhoto '11 Library Now Works.

    I finally got my problem solved....

    Turns out that there are some plug ins that are causing problems with the upgrade of the iPhoto library to iPhoto '11. I had the pleasure of meeting an iPhoto engineer (at my house), who took a copy of my 73 GB iPhoto library to Apple to determine why my IPhoto would crash during the library update. (Yes, I gave Apple my personal library). I was selected since I am near the Apple Campus.

    I told the engineer that they are playing with people's lives, because our photos are very important to us. He told me that they are aware of that, and are investigating the problem. (I had my library go from 73 GB shrink to 9 GB when I tried to upgrade to iPhoto '11.)

    It turns out an old plug in from the Joe Soft application, called Hear was causing my problem. Even though this was a iTunes enhancement application, it had ties to the movie files (via Quicktime) that are in my iPhoto library.

    Other plug ins that can cause problems are the DIVX plug in and AVI Converter plug ins.

    Once I removed the offending plug in, my library converted within a hour and I was happy to be enjoying the new version of iPhoto. I will keep my old iPhoto 9 Library, just in case if I have a problem. (I am testing importing photos from all of my cameras and iPhones, just to make sure import works.)

    I was also told that I can do the conversion in "Safe Mode" (hold Shift Key down during startup) if I didn't want to remove the plug ins. However, I needed to know if it was really the plug in, so I did the upgrade in the regular mode with the offending plug in removed.

    I have to say that I had moved a copy of the original iPhoto Library to a stripped computer (has no plug ins) and tried converting it to iPhoto '11, and it converted without any problems Therefore, I know it was a plug in issue.

    I was told that I can move the converted library to my main computer (that has the plug ins) and should not have any problems running iPhoto. The plug in problem only occurs during the conversion process.

    Regarding the Projects (Books) items, they all converted without any problems. I have open them and verified. All albums are working and all 26,000+ photos are working!

    I have shut down and restarted iPhoto and also shut down and restarted my computer, then launch iPhoto without any problems. I actually think iPhoto '11 loads much faster than iPhoto '09

    A regular fix is in the works.

    Hope this helps.

    Thanks again iPhoto Team!
  24. err404 macrumors 68020

    Mar 4, 2007
    This thread isn't too busy, so I'm assuming most people are able to update w/o issue. But the issues are severe enough that you need to take some precautions. As ticzon pointed out, it is possible to lose your photos. Be absolutely sure that you have a good backup prior to the install. Even if you already have a Time Machine backup, I'd recommend making a copy of your iPhoto library on your local disk to speed up a recovery if needed.

    For the record, once you have it installed, it's a nice upgrade from 09.
  25. badgerman macrumors 6502a

    Jun 9, 2008
    Tried this to no avail. Any other solutions?


Share This Page