iPhoto '11 Not Opening at All

Discussion in 'Mac Apps and Mac App Store' started by Coolnat2004, Nov 1, 2010.

  1. Coolnat2004 macrumors 6502

    Coolnat2004

    Joined:
    Jan 12, 2005
    #1
    So, I upgraded from iLife '09 to iLife '11. The install succeeded, but iPhoto won't open. It bounces a couple dozen times, then doesn't launch. It uses 100% CPU for a few minutes then terminates without displaying anything on the screen.

    I've tried repairing disk permissions and reinstalling. Has anyone else had this issue?
     
  2. burningbright macrumors regular

    Joined:
    Jul 5, 2008
    #2
    I have the same problem, on a Macbook 2,1. Anyone know of any solutions?
     
  3. GMikeyMike macrumors newbie

    Joined:
    Nov 30, 2010
    #3
    Check out the Apple support pages. It's littered with frustrated iPhoto 11 users and a few solutions. I am returning iPhoto '11 and going with Aperture. Someday Apple may fix this disaster, but I can't wait. My best advice is to switch to something else. I have had '11 since the early November and spent 100 hours on the phone with Apple support. Some of them are really great. But shouldn't the software work out of the box? You'd expect this from Microsoft, not Apple.
     
  4. tjb1 macrumors 68000

    Joined:
    Aug 26, 2010
    Location:
    Pennsylvania, USA
  5. T4R06 macrumors 65816

    Joined:
    Oct 8, 2007
    Location:
    CT
    #5
    over a month thread but i am in trouble too! what the heck...
     
  6. tjb1 macrumors 68000

    Joined:
    Aug 26, 2010
    Location:
    Pennsylvania, USA
    #6
    Yes or no...cant help you guys if you dont respond to your own thread and add to what you have done.
     
  7. RedRaven571 macrumors 65816

    RedRaven571

    Joined:
    Mar 13, 2009
    Location:
    Pennsylvania
    #7
    Apparently, adding your Bootcamp partition to Privacy in Spotlight may correct the problem; it did for me.

    Got that from an Apple support forum

    System Preferences > Spotlight > Privacy then either click the '+' sign and add your Bootcamp partition, or, if your Bootcamp Partition is visible on your desktop, just drag it into the Privacy section.

    iPhoto (iLife '11) wouldn't open on my MBP, running 10.6.6, starting yesterday afternoon. I updated to 10.6.6 weeks ago, don't know why this issue just started yesterday but this procedure corrected it.
     
  8. MrFusion macrumors 6502a

    Joined:
    Jun 8, 2005
    Location:
    West-Europe
    #8
    Make sure the frameworks are installed as well.
     
  9. jedimdan macrumors newbie

    Joined:
    Feb 4, 2011
    #9
    I registered an account on this forums just to say thank you, because I faced the exact problem as you did this week, and your solution worked perfectly.
     
  10. TRDannic macrumors newbie

    TRDannic

    Joined:
    Aug 11, 2010
    #10
    A solution that worked for me...

    I had the same issue with my daughter's iPhoto upgrade and was able to use Fat Cat software's iPhoto Library Manager to correct the problem. Use the “Rebuild Library” command and it will correct the library. Make sure you backup the library before (just in case).
     
  11. RedRaven571 macrumors 65816

    RedRaven571

    Joined:
    Mar 13, 2009
    Location:
    Pennsylvania
    #11
    Welcome to the forum; lots of good info is available here!

    ...and glad I could help!
     

Share This Page