iphoto '11 won't load correctly. HELP!

Discussion in 'Mac Apps and Mac App Store' started by kahandace, Dec 13, 2010.

  1. kahandace macrumors newbie

    Joined:
    Dec 13, 2010
    #1
    My iphoto is not working. When I open it, the picture loading swirl thing spins and never stops! Like it wants to load the events but it never does. I have uninstalled and reinstalled it twice and no luck! I Just got this computer a month ago. I have also tried the command+option to fix any problems. No luck!
     
  2. roadbloc macrumors G3

    roadbloc

    Joined:
    Aug 24, 2009
    Location:
    UK
    #2
    Have you updated to the latest version of iPhoto?
     
  3. tekchic macrumors 65816

    tekchic

    Joined:
    Apr 19, 2010
    Location:
    Phoenix, AZ
    #3
    I'm fighting with the same issue. Upgraded from iPhoto 09 to iPhoto 11. Deleted plist files for iPhoto, still no go.

    Occasionally it'll start up after a fresh reboot. Pretty irritating. Had I known there were going to be so many issues w/iPhoto 11, I wouldn't have bothered to upgrade.

    If you Google "iPhoto 11 won't launch" there are TONS of threads on the issue -- no great solutions yet.
     
  4. finchwizard macrumors member

    finchwizard

    Joined:
    Nov 15, 2005
    Location:
    Australia
    #4
    It's because it's not upgrading the Library properly.

    There is a 9.0.1 iPhoto update on the Software update, but you're supposed to have that before you try to open and upgrade your Library.

    I've been trying to fix a friends computer because of this, and he's got about 10 years worth of photos that aren't working.

    Sure you can retrieve them easily enough, but that's still a massive amount of work.
     

Share This Page