iPhoto 2.0.1 broken in 10.5

dantherevelator

macrumors regular
Original poster
Oct 8, 2007
148
0
Is iPhoto 2.0.1 compatible with Leopard?

I just upgraded my girlfriend's PowerBook G4 and iPhoto bounces and then quits unexpectedly. I deleted it and reinstalled it from her original DVD, applied -.0.1 update -- same trouble.

Here's what seems relevant from the error report.

Dyld Error Message:
Library not loaded: /System/Library/PrivateFrameworks/HTMLDisplay.framework/Versions/A/HTMLDisplay
Referenced from: /Applications/iPhoto.app/Contents/MacOS/iPhoto
Reason: image not found

Thanks.
 

ghall

macrumors 68040
Jun 27, 2006
3,773
1
Rhode Island
You may have to update iLife. It could be that the framework needed to run iPhoto 2 doesn't exist in Leopard or is significantly changed.
 

msmollynd

macrumors newbie
Mar 2, 2008
7
0
Is iPhoto 2.0.1 compatible with Leopard?

I just upgraded my girlfriend's PowerBook G4 and iPhoto bounces and then quits unexpectedly. I deleted it and reinstalled it from her original DVD, applied -.0.1 update -- same trouble.

Here's what seems relevant from the error report.

Dyld Error Message:
Library not loaded: /System/Library/PrivateFrameworks/HTMLDisplay.framework/Versions/A/HTMLDisplay
Referenced from: /Applications/iPhoto.app/Contents/MacOS/iPhoto
Reason: image not found

Thanks.
I just upgraded my PB G4 to Leopard and downloaded all of the updates. I am also having this exact problem, and I also cannot sync my iPhone, which seems to have to load iPhoto when I connect it.

Does this mean I must purchase and install iLife also, even though I only use iPhoto and it used to be free?
 

Virgil-TB2

macrumors 65816
Aug 3, 2007
1,143
1
I just upgraded my PB G4 to Leopard and downloaded all of the updates. I am also having this exact problem, and I also cannot sync my iPhone, which seems to have to load iPhoto when I connect it.

Does this mean I must purchase and install iLife also, even though I only use iPhoto and it used to be free?
Well if you purchased the last two OS upgrades you would have a more up to date version of iPhoto. ;)

Your version of iPhoto came out in 2003, and was obsoleted even before Panther came out. You must have used illegal upgrades or something for your switch to 10.3 and 10.4?
 

g-7

macrumors 6502
Feb 14, 2006
389
57
Poland
Well if you purchased the last two OS upgrades you would have a more up to date version of iPhoto.
iPhoto is not included in OS X. It is a separate application, you need to buy
iLife box to get it.

Anyway, it's a shame that Apple blocked running iPhoto 2 on 10.5 :(
 

iCeFuSiOn

macrumors 6502a
Jul 18, 2007
511
0
You'll need to upgrade your version of iPhoto to one that is compatible with Mac OS X 10.5. Either iLife '06 or iLife '08 would work great, you can buy a copy of '06 on eBay for around $30 USD.
 

msmollynd

macrumors newbie
Mar 2, 2008
7
0
Well if you purchased the last two OS upgrades you would have a more up to date version of iPhoto. ;)

Your version of iPhoto came out in 2003, and was obsoleted even before Panther came out. You must have used illegal upgrades or something for your switch to 10.3 and 10.4?
I have original installation discs. Please don't insult me. As I've learned since my posting, iLife is not included in retail versions of the OS, and I have to purchase it separately.
 

msmollynd

macrumors newbie
Mar 2, 2008
7
0
You'll need to upgrade your version of iPhoto to one that is compatible with Mac OS X 10.5. Either iLife '06 or iLife '08 would work great, you can buy a copy of '06 on eBay for around $30 USD.
Thanks, I am bidding on '06 on eBay now!
 

Similar threads

  • macdop
0
Replies
0
Views
186
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.