iPhoto 6.06 problem with external drive

Discussion in 'Mac Apps and Mac App Store' started by jblum, Jul 1, 2008.

  1. jblum macrumors newbie

    Joined:
    Jul 1, 2008
    #1
    I've been using my external Lacie FW drive for my iPhoto library. It accidentally got unmounted while I had iPhoto open, and now when I open iPhoto, all I get is thumbs and photos without any photos present.

    I have tried rebuilding and all 4 options that you get when you hold CMD-Option. I have searched the support DB with Apple and find nothing. The strange thing is each thumb has the meta-tag present in the "Info" menu, such as name, date, size, ect... but none of the pictures show. I have tried to mount and unmount the HD, create new libraries and the like, but it is as if the library won't reload a new library. Also, when I rebuild, it says it will take a while, but it only takes 15 seconds, so I don't think its actually rebuilding.

    I am totally stuck. I think I've tried everything. Any suggestions?
     
  2. jblum thread starter macrumors newbie

    Joined:
    Jul 1, 2008
    #2
    One more thing I noticed...

    ...my iPhoto application is 580mb. I'm not sure about the inner workings of iPhoto, but this seems bug to me. I thought all the data was stored externally and the program was just a reader for the data. I have some slideshows and books that I don't want to loose. Any suggestions given all this?
     
  3. cyclingplatypus macrumors 6502a

    cyclingplatypus

    Joined:
    Mar 15, 2007
    Location:
    Earth
    #3
    You could copy the library over to another iPhoto Library folder and use a helper program like iPhoto Buddy to mount the new folder.
     
  4. jblum thread starter macrumors newbie

    Joined:
    Jul 1, 2008
    #4
    Thanks!

    That is so amazing. I think iPhoto Buddy is the BEST singular piece of freeware I've ever seen. WOAH! Problem solved, thanks so much!
     

Share This Page