iPhoto Albums Not Visible From Within iTunes, Can't Sync to iPhone [Unkown Error -50]

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Compile 'em all, Sep 16, 2007.

  1. Compile 'em all macrumors 601

    Compile 'em all

    Joined:
    Apr 6, 2005
    #1
    Although having at least 10 albums in iPhoto, none of them are visible from within iTunes (as can be seen from the screenshot below). I have iPhoto 08' (7.0.2) and iTunes 7.3.2.

    [​IMG]


    I have rebuilt the iPhoto Library (holding down option+command while launching iPhoto), but it doesn't seem to fix anything. I have deleted as well albumdata.xml, and still no go.

    When attempting to sync photos to my iPhone, I get "unknown error -50". which is something to be expected since my albums are not properly detected from with iTunes.

    Anyone had a similar issue before?
     
  2. unity macrumors 6502a

    Joined:
    Sep 30, 2005
    Location:
    Green Bay, WI
    #2
    Is your photo library located where it is suppose to be? user/pictures/iPhoto Library ?
     
  3. Compile 'em all thread starter macrumors 601

    Compile 'em all

    Joined:
    Apr 6, 2005
  4. CJYetman macrumors newbie

    Joined:
    Nov 13, 2002
    #4
    I found a solution!!!!

    I had this same problem and it's been killing me. I've scoured the web and found no solutions. Some people said to delete all the keywords, which I unwillingly did to no avail! :-(

    I saw some posts saying it may be related to album names, and therefore suggested deleting any newly created albums. For me however, the problem was there from the beginning, so there was no way to tell which album name was causing the problem. I suppose I could have deleted all of my albums as I did the keywords, but that would have been impossible to repair.

    So, this is what I did....

    I went to my iPhoto library in the Finder. There's a file named AlbumData.xml. If you double click it, it should open in Safari. When I opened mine, at the top it said that it was displaying everything up to line so-and-so where there was an error. Good! Now I'm on to something. Next, I used the Find function in Safari to search for "AlbumName". The last "AlbumName" it found was just before the end of the file, so I went back to the next to last "AlbumName" and made note of the album name immediately after it. Then, I opened iPhoto, found the corresponding album in iPhoto to the next to last album name in the AlbumData.xml. Then I changed the name of the album immediately after it (which should have been the last album name in the AlbumData.xml file, but was not displayed because there was an error). Closed iPhoto, opened iTunes, everything works!

    Hope this helps someone 'cause it was killing me. :)
     
  5. raccoon macrumors newbie

    Joined:
    Sep 17, 2006
    #5
    Thanks!

    This helped me fix the same problem. My mistake was to call my external hard drive 'Music Videos & Photos', the '&' was screwing up the AlbumData file which meant that none of the albums appeared in iTunes.

    Renaming the drive and deleting the AlbumData file solved the problem. Thanks for pointing me in the right direction :)
     
  6. rockwhere macrumors newbie

    Joined:
    Apr 17, 2008
    #6
    Hum... this problem makes me think. I have a similar problem : cannot sync my iPhoto albums onto my iPod Touch. I though it was due to the fact that my album is located in a shared directory (from which iPhoto reads and writes properly. And unlike compile'em all, I do see all my albums properly listed).

    So after reading this thread, I think my problem may be that an accentuated character is present in the shared directory name ("Partagé" is French for "Shared").

    Problem : I cannot find the way to unlock that Directory to change its name!?!? Unlocked the folder in the Get info box, looked around the Web for a solution, nothing does it. Any suggestion? I would really like to try the "no accent" solution for my iPhoto sync issue. :eek:

    Thx.

    UPDATE : SOLVED

    I found that if one wants to change the sharing permissions of a file --or what looks to be a file like iPhoto but that in reality is a folder hidding a pile of files underneath-- three (3) things must be done :
    - unlock the permission settings (click on the lock, bottom right of the Get Info box; you will need the admin account ID and Password of course)
    - change the permissions at will for each entity : system, own and everyone (CAUTION : gotta know what you're doin' here!)
    - click the dented wheel at the bottom and select "Apply to all included files" (or it should say something like that in English I suppose; my system is in French. Says "Appliquer aux élément inclus")

    Hope it helps some folks out there. Thx to Racoon and Compile'em all who tipped me with their entries above.
     
  7. george9t8 macrumors newbie

    Joined:
    Sep 8, 2008
    #7
    If your ipod contains the most recent data, there's a much simpler way - delete the iopd forlder on the hard disk.
     
  8. Motrix macrumors newbie

    Joined:
    Jan 21, 2009
    #8
    i cant seem to find that AlbumData.xml file you were talking about
     
  9. hepeiyuan macrumors newbie

    Joined:
    Feb 8, 2009
    #9
    Right Click on it.

    To view AlbumData.xml, find your iPhoto Library in the Finder, and click on the library bundle while holding the control key (or right-click), and choose Show Package Contents. This should reveal the AlbumData.xml file which can then be drag-and-dropped onto your text editor. Once you have opened the AlbumData.xml file, navigate to the problematic line number indicated in the error message. You will see data like the following.
     
  10. Undecided macrumors 6502a

    Joined:
    Mar 4, 2005
    Location:
    California
    #10
    Thanks for sharing - that enabled me to fix the problem for me too. In my case, I could see the name after the last AlbumName, so it was easy for me to identify the offender. I just blew it away (it was a slideshow) and all is well again.
     
  11. cardertd macrumors newbie

    Joined:
    Sep 9, 2009
    #11
    for all you photo sharing types...

    If your iPhoto library package has been moved from the user's Pictures directory (I keep mine in the main Shared directory and iPhoto is doing fine -- just iTunes won't sync photos with my phone), the problem is probably related to permissions. My iPhoto library retained it's permissions when moved, so "Me" (user) and "Everyone" (group) had Read + Write permission, but "System" didn't.

    A-ha. The iPhone or iTunes must use "System" to access the photos when syncing, and "System" must not be a member of the "Everyone" group.

    =====

    I shutdown iTunes & iPhoto, did Get Info on the main Shared directory (noticed that "System" has full access -- the only difference I noticed in permissions), and chose 'Apply to enclosed items' in the gear menu at the bottom. You might have to make a permission change for this to happen, so add a new user or group, delete it, then 'Apply to enclosed items'.

    This copied the permissions of the main Shared directory to all subfolders, which added the "System" user to the iPhoto package. As soon as I opened iTunes, with my iPhone connected and showing in the Devices list, I saw the option to specify folders and events when syncing Photos.

    =====

    BTW, there are some very nice improvements to photo syncing in the new version of iTunes (9.0). Fix this problem soon. You don't know what you're missing.
     
  12. HadItWithWindow macrumors regular

    Joined:
    Dec 1, 2008
    #12
    Strugle with Unknown Error - 50

    I've read the forums and still need some help. Be patient. I'm a windows user . It's taken me two days to figure out how to open AlbumData.xml. These controls are really new to someone use to right click only.

    The AlbumData.xml files is huge. There is no way I can see to locate 'error'. I've spent twenty minutes trying to find on since I cannot sync my iPhone with photos. It creates an error message. Is there a way to search for the word 'error' in the .xml file?

    I think the problem may be what a previous poster refers to as permissions. Can someone please go slow and a step by step (which control/shift, etc) to click to find permissions and resolve that possible conflict?

    A basic understanding of iPhoto is also needed. When I upload pics from my cam it apparently goes into 'library'. Then I create these albums and move from library to 'albums'. If I delete from 'library' is also deletes from 'albums'.

    Is the proper way to upload photos to your mac to let them go by default into library and then drag them to new albums? Am I correct to assume that all photos go in library and the only advantage to albums is the sort?

    I did not have this problem (unknown error -50) until the latest updates to Safari. I don't use Safari but use Firefox instead. Could this be a related issue?

    Also, on my iPhone I don't have any pics from my Mac library. Just those I shot with the not-to-good iPhone cam.
     
  13. patwlee macrumors newbie

    Joined:
    Dec 4, 2009
    #13
    & character is the problem

    I have the same problem to open iPhoto from iTunes to sync my iPod Touch.
    I use both Safari and TextEdit to open AlbumData.xml file.
    Safari stops at the error code.
    TextEdit does not stop at the error code, it continues to show all the code.

    So, I compare both Safari and TextEdit.
    Where Safari stops and where TextEdit continue is where the problem lies.
    I found out one of my iTunes songs which I use for one of my iPhoto Slideshow has a "&" character. So, I remove the song from iPhoto Slideshow, and the problem solved.
     
  14. skip2820 macrumors newbie

    Joined:
    Jun 11, 2010
    #14
    In the iPhoto Library folder, I searched for a folder name with '&' and renamed it.
    That automatically displayed the new Albums in Itunes with the right number of pics in them.

    No need to deal with AlbumData.xml in Safari or TextEdit.
    Every time you create or delete a folder, AlbumData.xml gets updated automatically.
     

Share This Page