iPhoto and iMovie bug. Need help!!

Discussion in 'Mac Basics and Help' started by IzzyJG99, Mar 24, 2011.

  1. IzzyJG99, Mar 24, 2011
    Last edited: Mar 24, 2011

    IzzyJG99 macrumors 6502

    Joined:
    Oct 26, 2007
    #1
    Hi, Guys. I upload videos from my Flip UltraHD to iPhoto. It's the way I've always done it. But only recently started to use iMovie to produce videos. I have run into a problem. Yes, I shouldn't do it this way but I'm an idiot and can't redo (No time!) 77 videos.

    I'm running iMovie 8.0.6 and iPhoto 8.1.2.

    The problem is if I import a video into iPhoto and then allow the thumb nail to be generated in iMovie...and I want to get rid of the video because of a bad cut (usually stuttering on my part) I run into a problem. I delete the video from iPhoto. I reshoot and then I then upload the new video. Tt shows the old video thumb nail with the old audio, but shows the new video. HELP!

    Do you suppose it's because the Flip always generates movies with the name 0001 (And 0002 and so on) and iMovie/iPhoto sees the same file names and associates them together? This bug doesn't occur if the 0001 video is imported on a different day since I have tons of 0001 named videos that haven't had this problem. Since I delete the videos off of the Flip after each use like the rest of humanity...each new movie then begins as 0001.

    If that's the case is it safe to just drag-n-drop the video from the Flip onto the HD and rename it so this doesn't happen again? Each time it does happen I have to copy my back-up photo library and movies folder back to the HD to "wipe" the programs clean of this bug.
     
  2. IzzyJG99 thread starter macrumors 6502

    Joined:
    Oct 26, 2007
  3. Dave Braine macrumors 68040

    Dave Braine

    Joined:
    Mar 19, 2008
    Location:
    Warrington, UK
    #3
    A good tip is to start filming before and stop filming after what you actually want to film, then you can trim the clips to get rid of the bad cuts.

    Have you tried importing the new clip into iPhoto before deleting the unwanted clip.
     
  4. IzzyJG99 thread starter macrumors 6502

    Joined:
    Oct 26, 2007
    #4
    I haven't. I'll have to give that a try.
     
  5. IzzyJG99, Mar 27, 2011
    Last edited: Mar 27, 2011

    IzzyJG99 thread starter macrumors 6502

    Joined:
    Oct 26, 2007
    #5
    Update: Okay so I tried what you mentioned.

    Filmed a clip which the camera named 0001. Imported to iPhoto. Then iMovie.

    Filmed a second clip which the camera named 001. Imported to iPhoto. Then iMovie.

    In iMovie it shows the two separate clips and their thumbnails properly. But d show up as the same date, but as two different events with the very same date. It's not even showing up as "Sunday, March 27th 2011_1" like some other clips I have imported later show up. That was probably a hold over from previous versions of iLife.

    So then I deleted from iPhoto the first 0001 clip. The original 0001 thumbnail is gone (as it should be) and the second 0001 clip works fine. Video is good. Thumbnail is good. Works fine.

    I should also mention that I've upgraded to iPhoto 11 and iMovie 11 now on Friday. I notice there are some preferences in iPhoto that might fix this problem I was having. Options and such that are as far as I know only in the 2011 version. Or at least I didn't see them in 2009. Namely that iPhoto 11 leaves each Event as "untitled" and doesn't just give it the date of import, but requires you to type all that in yourself. Personally I think the "Event" crap adds more useless problematic organization and file path problems. Half of my videos say the date. Others that are in albums (but not all) say the album they're in as the event. And even if you change the event name it still doesn't change in iMovie. Annoying for people with OCD like me, but survivable.

    Here's what I did next to test it all out to see if the bug can be fixed with the new preferences in 2011. I left the preferences at what they are by default. Didn't change any event splitting or anything.

    I imported 0001 into iPhoto. Did the iMovie. Generated thumbnail. Then I did what I did before that caused the bug. Went into iPhoto and deleted the video. THEN I REALIZED that evidently the movie doesn't get totally deleted and still remains in your trash. Emptied Trash. Imported another movie as 0001 and the problem wasn't there at all. Right thumbnail, right video and right sound. THANK GOD.

    I think the problem is that you gotta remember to empty your trash. Which I can't recall as an option for the 2009 version. It probably was and I never noticed which makes me feel like a complete idiot.

    I tried it WITHOUT emptying the trash and guess what? No conflict. So it seems this was a bug inside of 2009 (Possibly previous versions) and/or required you to go back and make sure you emptied your trash. It also seems that assigning "events" to each import in 2011...prevents this bug from happening, too. So I guess I'm glad to have Events now? Weird how stuff works out.

    Glad to know it's fixed by Apple at least!
     

Share This Page