iPhoto -> Aperture import problem

Discussion in 'Digital Photography' started by kmaute, Oct 4, 2010.

  1. kmaute macrumors 6502

    kmaute

    Joined:
    Oct 5, 2008
    Location:
    USA
    #1
    Hey all,

    This problem has been driving me crazy and there has to be a solution. I upgraded to Aperture from iPhoto last year and everything was going swell. I got a new Mac and did a clean install, moving over my iPhoto and Aperture library. Stupidly, I should have consolidated my masters or something because Aperture is looking for my iPhoto library in the old directory and is not linking to my master images.

    In short:

    Aperture is looking for the iPhoto library in:

    OldComputername:/Users/oldusername/Pictures/iPhoto Library

    When it needs to be looking for:

    NewComputername:/Users/newusername/Pictures/iPhoto Library

    Is there anyway to fix this? Much appreciated...

    Ken

    ETA: Sorry, need to add that I know about "Located Referenced Files" but if I try to enter iPhoto library from the aperture interface - I cannot see the photos at all. Thanks...
     
  2. kmaute thread starter macrumors 6502

    kmaute

    Joined:
    Oct 5, 2008
    Location:
    USA
    #2
    Okay, I've done some more digging around. It appears that the latest version of Aperture has a bug that prevents the Locate Referenced Files tool from seeing into iPhoto libraries. I pulled the originals folder out and am reconnecting referenced files as I type (84%). Hopefully, this will resolve any problems. Hope this helps someone else. Thanks.
     

Share This Page